Jump to content
Welcome to our new Citrix community!
  • 0

Unable to Install workspace 2106 - no existing clients found with given upgrade code in log


David Murphy1709162767

Question

(***corrected 2016 to 2106 version) 

 

Hi all, 

 

I have been trying to install HDX RealTime Media Engine 2.9 for windows, and kept getting a error that I needed Workspace installed first. This was odd as I was running Workspace (2009) for a very long time - during the lock downs all remote work etc.... today I figured I would try and UNINSTALL all/anything CITRIX currently on device to "start fresh" and see if I could install Workspace 2106 and then get the HDX RealTime Media Engine to work (HDX is supposed to help with remote audio/video for meetings using SKYPE or ZOOM etc.... which is a bit glitchy at times in the remote work world) - anyway after uninstalling all the CITRIX components I could locate and then downloading and attempting to install Workspace 2106 (DL direct from CITRIX not via any Windows store or interface) I get the error shown below in the log. 

 

About to try and run the clean up utility, but any other help or suggestions would be appreciated, I'll fall back to a restore point if I can't get it working, but this shouldn't be this difficult - I'm thinking there must be another install file that I can use that doesn't; look for a prerequisite earlier version, or perhaps I have to install an earlier version and then try and update? Seems illogical. 

 

DELL XPS 8930

i7-8700 @ 3.2 GHz

32.0 GB

64 bit

 

WIN10 Pro

DEV

05/26/21

21390.2025

Experience Pack 321.13302.10.3

 

 

 

 

09:02:31: Information - CtxInstallHelpers::CInstalledClientPkg::FindInstalledClient(154) - No existing clients found with given upgrade code: {9FAB00CA-B032-4E4E-8D0C-E3B35802335D}
09:02:31: Information - CComponentManager::GetInstallStatus(652) - Repairs RTME plugin with Product code =  
09:02:31: Information - CComponentManager::GetInstallStatus(661) - CommandLineParameter is =  msiexec /i  /quiet
09:02:31: Information - CFinishDialog::OnInitDialog(170) - app.LoadIcon return code. GetLastError: 0
09:02:31: Information - CFinishDialog::OnPaint(644) - draw icon return code. GetLastError: 0
09:02:31: Information - CFinishDialog::OnPaint(644) - draw icon return code. GetLastError: 0
09:02:33: Information - CFinishDialog::OnViewLogClicked(262) - OnViewLogClicked(): Entry.
 

Link to comment

1 answer to this question

Recommended Posts

  • 0

This issue has been resolved. Turns out I had some CITIX components, perhaps orphaned failed installed components in some hidden folders that were not allowing me to delete the instance of  WORKSPACE 2009 that was showing.  Finally went through the process of booting into safe mode, searching for EVERYTHING that had CITRIX including anything hidden, and deleted all folders.  Emptied recycle bin and rebooted.  One odd issue was that I could still not install the 2106 version direct from CITRIX download, and had to install the version from the Microsoft Store (v 21.6.0.0).  So that issue is resolved and I can at least remote into office and work (yeah I guess ;-)) - HOWEVER - with the above issue resolved, I attempted to install the HDX_RealTime_Media_Engine_2.9_for_Windows.msi and it will NOT install, i get a message that says I need to have Workspace installed first, which I clearly do now. So a bit confusing on that issue. I deleted the version I had downloaded from CITRIX before I corrected the described problem above and then downloaded a new/fresh copy - but still same error.  So will be working on that issue to try and resolve, and if there is anyone with hints/tips on installing the HDX media engine - I would appreciate any insights.  

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...