Jump to content
Welcome to our new Citrix community!
  • 0

Can't connect to VDA in Azure with RDP


Question

We run a Citrix Cloud solution with our Workload servers (VDAs) in Azure. We provision the MCS image with Azure ARM templates and do install all our applications with MDT afterwards.

After we have created the image, I do use MCS to create/update the machines in production.

But here is the strange thing, everyday we have around 50-70 % of the VDA's not accepting RDP connections. Witch machines that have this problem is random from day to day. When the machines have this problem, it will not accept RDP sessions before we restart it at night. If it works then, that is random.

When we got this issue, we can see that winlogon.exe is making an record in the app eventlog , "The Windows logon process has unexpectedly terminated"

I have worked with both Citrix support and MS support from December 2020, but we still have no solution to this. They can see that the session is waiting to create mouse/keyboard mapping, and this process is timing out after 15 sec. and that is where I got this Winlogon error. So when I try to connect with RDP, the MSTSC is hanging on securing connection, and after 15 sec. its just go back to the connect window, no error message. We have tried to do alot of tracing, but its not thart easy, because of MCS that is resetting the image. MS wants me to do a tracing when I restart the Terminal Services, but when I do this I get also disconnected from the ICA session, and the servers get unregistred and shutsdown. So its not possible.

 

But what I think is wired is that I have not found any other companies/users with this problem reported in forums or other places. Since we use an ARM template to create the machine, this should be something other Citrix Cloud users also see? We have tried almost all VDA versions from 2020, and I now running at 2103, same problem on all of them. We are running Windows Server 2016 in Azure Norway East and Azure West Europe. Is there someone out there that have seen the same ?

Link to comment

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...