Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Xenserver 7.1cu2 hw upgrade > Supermicro X11DPH-T random network reset Intel® X722 + X557


Aleksander Kikkas

Question

Hi,

 

We have a Citrix Xenserver 7.1CU2 licensed eneterprise per socket.

We did the hw upgrade to  Supermicro X11DPH-T Intel® X722 + X557 (clean install and export/import vm-s), latest updates, latest xencenter

 

Under heavy network load importing vm (1Gbit/s) the  Intel® X722 + X557 randomly reset

 

This was not an issue in 8.2, but 8.2 does not allow to use the license file   issued to our server.

 

We tried different switch-s but not at native 10Gbit/s

 

I know in ubuntu had similar problems with intel-s ethenet adapters resetting and fixed with permanent ethtool commands like:

 

up ethtool -s eth1 wol d
up ethtool -G eth1 rx 1024 tx 1024
  ### i217 device hangs ocassionally in dmesg...without following:
up ethtool -K eth1 tso off

 

 

Maybe buffer/etc tunings

 

Kind Regards

 

Aleksander Kikkas


 

Link to comment

3 answers to this question

Recommended Posts

  • 0

Self ask - self answer...

 

It seems, that this is known issue as 7.1 comes with very old drivers.(i40e: Intel(R) Ethernet Connection XL710 Network Driver - version 1.3.46-k)

 

https://support.citrix.com/article/CTX231142

 

We have a License, that says "Eligible for support" can download updates etc but:

 

https://support.citrix.com/article/CTX226402

 

is not accessible ;(((

 

Very strange politics

 

Maybe any other way how manually update to Intel i40e-2.0.23 ?

 

Aleksander

 

Link to comment
  • 0

Yee - It works now...

 

We have now much newer driver, than Citrix provide (2.0.23) through Customer Premises support...

The magic was DDK.

 

Steps to make it work:

1) Download DDK 7.1 and import it.

 

2) Login into the DDK via ssh

 

3) Download the intel driver source to the DDK:

wget https://sourceforge.net/projects/e1000/files/i40e stable/2.11.25/

 

4) Build RPM

rpmbuild -ta i40e-2.11.25.tar.gz

 

5) Export RPM to the Citrix DOM0

 

6) On DOM0 

rmmod i40e

 

7) On DOM0

rpm ivh i40e-2.11.25-1.x86_64.rpm

 

8) On DOM0

cd /boot

dracut –f initrd*

 

Kind Regards

 

Aleksander Kikkas

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...