Jump to content
Welcome to our new Citrix community!
  • 0

"You reached the maximal number of concurrently migrating VMs." but no tasks in xe task-list


Jimmy Koerting

Question

Hi,

 

after 3 failed cross pool migrations (for hours) where I was unable to cancel the migration tasks, I did a xe-toolstack-restart. But now, I get the message from the title, without having any tasks at all. Live migration between the hosts within the same pool and other things working, but no cross pool migrations.

I have to migrate all VMs from the pool, so I'm in trouble :(

 

Is it known, if there is another place (after the toolstack restart) - maybe a lock file or whatever -  where the (wrong) information about the previously running migrations is still alive? Can this be resetted anyhow?

 

Many thanks in advance!

Link to comment

8 answers to this question

Recommended Posts

  • 1

You could try looking for active processes using "xe task-list" and see if there is any active migration task.

 

Hard to say, otherwise. You could try migrating the VMs off one of your hosts to another host within that same pool and see if rebooting the host helps; if not cycle through the rest (making sure to designate a new pool master before rebooting the current pool master, of course).

 

 

-=Tobias

  • Like 2
Link to comment
  • 0

Tobias,

 

yep - that is exactly what I've done by now, but nothing helped. I guess, I have to shut down all VMs and hostmaschines, but as this is a productive pool with customer VMs that would be the last resort I want to avoid :(

Maybe of interest:

- after some hours, I was able to start cross pool migrations, but the stuck at 0% and no progress even after a full night.

-using xoa orchestra (where I can decide which network to use for the transfer), it's working when I select a different network (management with low speed instead of storage with 10G)

 

Ever heard of that?

 

Link to comment
  • 0

Jimmy,

Interesting. The primary management interface can indeed in many cases be the slowest option.  Have you run "iostat -x 10" and monitored what the resource I/O usage looks like? Maybe your dom0 installs need more VCPUs and/or memory? You can run top or xentop to see about the dom0 (and in the case of xentop, also the individual VM) CPU and memory usage.

 

-=Tobias

Link to comment
  • 0

Tobias,

 

as always: thank you very much for your input! At last, I took a heart and stopped all VMs and hosts. After restart, all is running like a charme. It semms, sometimes one need that.

 

Some personal thing: I saw your picture with the guitar and had to smile. In the old times (last century - strange one can say that) I was a guitar luthier - ask google for 'jimmy koerting guitars' or 'James Tim Koerting guitars' to see some things like articles in some german music papers from the nineties. I miss that times. Wood and steel are friends compared to computers :)

 

best of luck,

jimmy

 

Link to comment
  • 0

Jimmy,

Awesome - so glad that worked! BTW, that's a $3500 Martin at the Nashville Country Music Hall of Fame gift shop I just had to try out!

I have total respect for anyone who can create such instruments! What a gift.

 

-=Tobias

 

P.S. Did you ever check if NTP was properly synchronized on all hosts?

Link to comment
  • 0

hmm, all hosts in the pool gave values like this on ntpdate:

server x.x.x.x, stratum 2, offset -0.000066, delay 0.02605
server x.x.x.x, stratum 2, offset -0.000239, delay 0.02612
19 May 18:08:30 ntpdate[32335]: adjust time server x.x.x.x offset -0.000066 sec

 

None of the hosts had offsets greater than 0.001 sec - so, in my view, the times should be in sync on the hosts. Or should I check this a different way?

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...