Jump to content
Welcome to our new Citrix community!

The server met an error. Please try again or contact your administrator


Sasi Tzdaka

Recommended Posts

Hi,

I have citrix gateway 12 vpx
For some reason he writes me this message
The server met an error. Please try again or contact your administrator
Once I change the setting in the Clientless Access session profile from OFF to ON I can connect
What could be the reason?

 

Link to comment
Share on other sites

You need to share more info on your configuration.

Are you doing vpn, ica proxy, or clientless access?

 

What are the other details of the session profile in use?

- Clientless access allows access to web urls proxied by the gateway only and depending on whether setting is ON (clientless mandatory), OFF (clientless optional), or DISABLED (no clientless) would affect results.  Now, previously (not sure if it changed 11.1 and later or 12.0 and later, the terms were ON/ALLOW/OFF to correspond to the later ON/OFF/DISABLED)

- Clientless access though is somewhat dependent on whether the ICA PROXY setting is ON vs OFF with a storefront url specified.

 

But if you are trying to do clientless access only to vpn web bookmarks that are marked proxied by gateway, then clientless access must be ON to do clientless only. (The "off" value depends on which terminology you see.)

If you are trying to do ICA Proxy but the connection is failing and you are falling back to clientless only, then there is likely an issue in your ica proxy settings.

 

Check syslog for more info on gateway issues:

shell

cd /var/log

tail -f ns.log | grep -v CMD_EXECUTED

 

Or view all log events in System > Auditing. Then Current syslog messages in the right pane.

You are looking for events related to authentication (AAA) or authorization (Allow/deny) or ssl vpn vserver events.

 

Link to comment
Share on other sites

  • 3 months later...

 Error after login to Citrix Gateway : : "Please log on The server met an error. Please try again or contact your administrator" 
Works fine internally, through Storefront server.

Environment

This is for the latest verson of Citrix ADC 13.0

1. Verify if the session policy is getting a hit using below command :
nsconmsg -d current -g pol_hits -g pcb_hits 

2.Remove "REQ.HTTP.HEADER Referer EXISTS"  from the policy expression 

3. Click Done 
 

Upgraded ADC: Incoming HTTP request towards the gateway does not have  Referer header 

Additional Resources

 

See if this works

  • Like 1
Link to comment
Share on other sites

  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...