Jump to content
Welcome to our new Citrix community!
  • 1

Citrix Session freezing on HP t420 / ThinPRO 7.1


Mojmir Vajgel

Question

Hi 

 

I had upgraded a couple of t420 to ThinPRO 7.1 SP 12 (Ubuntu based) with Citrix Workspace App 2012 because we needed HDX optimised Teams on Citrix, our farm is 1912 CU2 LTSR. This is actually working great, but on upgraded thin client the Citrix session ocassionally stops working. Only mouse is moving, but the session does not respong on mouse clicks and the keyboard it not working as well. But the session on the server is running properly, the clock is changing. The user has to hold the power button, start the TC again and connect to the same session.
This issue is just on the upgraded TCs.

I tried everything possible, differrent Workspace version (2006, 2010), changing Workspace configuration, even BIOS update but nothing helps. Did you hear about such issue and eventually got it resolved?

Many thanks.

REPLY

Link to comment

15 answers to this question

Recommended Posts

  • 0

Hi,

same issue here on T530 with ThinPRO 7.1 SP11 and Workspace 2012. Tried upgrading to ThinPRO 7.2 SP1 but nothing changed.

As a workaround users press CTRL+ALT+END to get to the local OS and restart their session.

Seems like a Workspace problem. In addition the thin clients are listed with a localhost IP (127.0.0.1) instead of the real one in Citrix Director (EndPoint IP).

 

Waiting for new version.

 

Helpdesk SES

Link to comment
  • 0

Hi All,

 

I am experiencing the same issue as well, I have yet to find a resolution either. It's frustrating, but I'm glad I'm not the only one experiencing the freezing. "CTRL+ALT+END" has been my work around as well, minimizing the session then restoring it to get our users back and working. If I find a fix, this will be the first place I report it. 

Link to comment
  • 0

Hey friends,

 

we bought thirty HP T640 with ThinPro OS. Usually we have windows TC's but they were not available.

 

Workspace App 2009 was installed and users are complaining that their session freezes randomly.

Workaround is to change their workplace and connect from another TC to the running session.

The session is still working so I guess workspace app is the cause.

 

Our Farm is running on 1912CU2 LTSR and 2019 Server.

 

We are now trying some older Workspace App versions..

 

Best wishes,

Marcel

Link to comment
  • 0

Hi there,

Same issue here with HP t630 on ThinPro 7.1 and 7.2 and various CWA versions. It happens regardless of the location of the thin client (internet vs LAN). Sometimes, the ‚minimize‘ shortcut works, sometimes it doesn‘t and I have to kill the wfica process on the thin client and perform a reconnect or power-cycle the client. I have the feeling that it is more common to happen during some multimedia activities (video, audio). We have no such reports on non-ThinPro clients.

Has anyone of you already opened a ticket with HP or Citrix on this?

BfN, Konrad

Link to comment
  • 0

I found the following similarities between the freezes:

/tmp/connection-mgr_Web Browser_{<GUID>}.log

[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
wfica.bin: ../../src/xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Aborted

So far, all the freezes that I checked this log afterwoods, showed the same lines at the very end of the log file.

Link to comment
  • 0

Hey guys,

I've installed ThinPro 7.2 SP3 few days ago and I have the feeling that it did improve the s(h)ituation. So far, 3 days in a row without wfica hang.

Maybe TP7.1 SP16 brings the same relieve?

BfN, Konrad

 

NB: SP3 changed the resolution scaling from 100 to 150%, but a registry tweak on the thin client brought all back to 'normal' (users/user/autoscale=0, users/user/desktopScaling=100)

Link to comment
  • 0
17 hours ago, Karim Messoussi1709163006 said:

Hello,

 

Has the issue related to IP 127.0.0.1 also been fixed with the latest service pack please?

 

BR

 

No I can confirm the issue still exists, came across it trying to resolve the freezing issue as we also need Zoom for VDA which requires the newer Workspace app. Director 1912 shows 127.0.0.1 for all endpoint IP's running ThinPro 7.2 SP 5.5 and Workspace 20.12.0.12. I have NOT yet tried the newer Workspace 21.06, but in release notes that version also seems to have other known  issues with Teams screen sharing etc. Seems HP and Citrix both have more work to do here.

 

EDIT: Workspace 21.06 seems to resolve the 127.0.0.1 IP address issue, at least in Director

Edited by Evan Ractivand
New indo
Link to comment
  • 0

We have recently upgraded from Thinpro 6.2 to 7.2 SP 9.3 and have this freezing issue.  It seems to happen to about 12/1000 units per day.

 

I have a suspicion that it's related to the Webex Meetings VDI plugin but have not been able to prove that just yet.  When the IO starts to ramp up, I can see a number of BTRFS related "kworker" processes on the thin client driving the IO.   It doesn't take long before the UI becomes unresponsive and nothing short of a power off solves the issue.

 

Does anyone here know if a solution was ever found?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...