Jump to content
Welcome to our new Citrix community!
  • 0

You have not chosen to trust "DigiCert Global Root G2", the issuer of the server's security certificate


s per

Question

I am getting the following error on my MacBook Pro when I run a Citrix app

You have not chosen to trust "DigiCert Global Root G2", the issuer of the server's security certificate.

 

Quote

Laptop specs:
BigSur Version: 11.2.3 (20D91)
MacBook Pro (Retina, 15-inch, Mid 2015)
Intel Iris Pro 1536 MB

 

Citrix Workspace Version: 21.02.0.29 (2102)


Earlier I was running Sierra and once logged in through my browser, I would click on the ICA file, this would automatically open my remote desktop.

Now, I get the error above when I click on the ICA file.

I found a solutions online
1) reinstalling Citrix
2) Adding Digicert g2 in /Applications/Citrix ICA Client/keystore/cacerts

none worked

 

ps: I've also installed the beta version of citrix preview app Version: 21.04.0.8 (2104) but it's still throwing the same error

Any help will be appreciated. Thank you

 

 

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...