Jump to content
Welcome to our new Citrix community!
  • 0

Citrix app on new MacBook Pro (Intel) does not map keys correctly (cannot type braces, shift+6 does not give ^, ...)


Frederic Desgreniers

Question

Using the latest Mac version 11.2.3 and downloaded the latest Citrix Workspace app today on my new MacBook Pro (Intel). Keys such as {}[]^ all work when typing normally (as I'm typing them right now) but they do not work when I use Citrix to connect to my work computer. If I pop up the windows 10 on screen keyboard on it, [ and ] keys say that I'm pressing alt (??) and when I do shift+6, instead of giving me ^ it gives me [. Shift+2 shows up first as pressing shift, then when I press 2 it says I pressed alt. However 2 by itself works fine. 

 

I've tried every combination in the preference menu, nothing changes anything.. I'm using Canadian English keyboard on my windows, have tried US, but no luck there either .

 

I've wrestled this for about 5 hours today, anyone have any tips on getting it to work? (I've uninstalled and reinstalled Citrix Workspace app about 4 times now with no progress..)

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...