Jump to content
Welcome to our new Citrix community!
  • 0

Director: Cannot retrieve the data


vbanjeg46

Question

HI guys,

 

Need some help.

 

We had some problems with Monitoring database se we  did restore.

After that citrix director is have problems with statistical data.

"Cannot retrieve the data. View Director server event logs for further information." Refer Citrix KB article CTX130320

 

image.thumb.png.a412092ce93345b7f77eb30b8dcf3455.png

 

Citrix Virtual Apps and Desktops 1912 LTSR CU1

 

We tryed this but didn't help:

https://support.citrix.com/article/CTX208206

 

Any suggestion ?

 

Thank you

 

Link to comment

5 answers to this question

Recommended Posts

  • 0

 

Hi Vedran,

 

Can you test the new database connection strings and verify all okay ?

 


asnp citrix.*

$ServerName = "<dbserver>"
$SiteDBName = "<SiteDbName>"
$LogDBName = "<LoggingDbName>"
$MonitorDBName = "<MonitorDbName>"
$csSite = "Server=$ServerName;Initial Catalog=$SiteDBName;Integrated Security=True"
$csLogging = "Server=$ServerName;Initial Catalog=$LogDBName;Integrated Security=True"
$csMonitoring = "Server=$ServerName;Initial Catalog=$MonitorDBName;Integrated Security=True"

Test-AcctDBConnection -DBConnection $csSite
Test-AdminDBConnection -DBConnection $csSite
Test-AnalyticsDBConnection -DBConnection $csSite   # for 7.6 and newer
Test-AppLibDBConnection -DBConnection $csSite      # for 7.8 and newer
Test-BrokerDBConnection -DBConnection $csSite
Test-ConfigDBConnection -DBConnection $csSite
Test-EnvTestDBConnection -DBConnection $csSite
Test-HypDBConnection -DBConnection $csSite
Test-LogDBConnection -DBConnection $csSite
Test-LogDBConnection -DataStore Logging -DBConnection $csLogging
Test-MonitorDBConnection -DBConnection $csSite
Test-MonitorDBConnection -Datastore Monitor -DBConnection $csMonitoring
Test-OrchDBConnection -DBConnection $csSite       # for 7.11 and newer
Test-ProvDBConnection -DBConnection $csSite
Test-SfDBConnection -DBConnection $csSite
Test-TrustDBConnection -DBConnection $csSite      # for 7.11 and newer

 

 

Thanks

Manoj

 

Link to comment
  • 0

HI,

 

Yes, i tried and here are results for monitoring database, which we are having problems with:

image.thumb.png.ec16d519e2eaaed23dcdd61c7ee43908.png

 

Status is same for all other tests (I checked also from secundary delivery controller)

 

I see on SQL manager that Monitoring DB is not synced:

image.png.3625bcb8e9c5efccef337d7a4537bf8f.png

 

As I said, problem started when we did restore of Monitoring DB.

Last backup was a year ago (please don't ask me why :) , I'm not responsible for backup)

Of course, after that situation backups are done on regulary basis

 

Thank you in advance

Link to comment
  • 0

HI,

 

Yeah, here are screenshots.

You can see permisions for both delivery controllers:

 

image.thumb.png.1c00b3d6d70a370ff066d39aeefe7b5f.png

 

 

But I just remembered something...

At first site was 1912 LTSR, and after that wi upgraded it do 1912 LTSR CU1.

And it is working on CU1 for at least 7-8 months.

 

Monitoring DB backup was from state when site was 1912 LTSR without CU1.

And now this backup is restored.

 

Maybe there is some mismatch beetwen these two versions ?

Is it maybe easier to create new Monitoring DB and then change connection stings from both delivery controllers ?

Link to comment
  • 0

Update :)

 

After my DB admin successfully solved problem with Monitoring database sync

image.png.72103511a1926dc3141e65b0f67c4145.png

 

Director started to work.

But.... Sessions are connected:

for example, in Studio I see

image.png.f5fa0472ab636d1f0ee56879b6b186fc.png

 

But Director is showing: 0 session connected

image.png.1fc31fcbea30eb48629bad516e21d125.png

 

Little bit confusing :)

 

Any clue ?

 

Thank you.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...