Jump to content
Welcome to our new Citrix community!
  • 0

Studio MMC could not create snap-in after 7.15 LTSR CU6 or CU7 upgrade


Grant Lui

Question

Hi everyone,

 

We are evaulating 7.15 LTSR CU7 upgrade from 7.15 LTSR CU3 on an isolated test environment (without internet), we used the same environment previously in evaluating the upgrade from 7.6 to 7.15 LTSR CU3, everything runs perfectly.

 

Preliminary site tests passed and nothing unusual reported.

 

66123129_Upgradescreen1.thumb.jpeg.453bde30b994b2e147304a99b394dc52.jpeg

 

All steps of upgrade (including the interim reboot betweens) completed without any errors and warnings.

 

Unfortunatelly, Studio fail to open (We ran with a domain admin account) at first launch after the upgrade.

 

1168369242_Upgradescreen2.thumb.jpeg.3ff9ee23a8b3a9a7cc5f42a556b0f99d.jpeg

 

Message shows:

The snap-in might not have been installed correctly.

CLSID FX:{147c3fb4-2709-47cd-8745-7ea822341189}

Could not load file or assembly "MmcSnapin, Version=7.15.700

 

   at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)
   at System.Activator.CreateInstance(String assemblyName, String typeName)
   at System.AppDomain.CreateInstanceAndUnwrap(String assemblyName, String typeName)
   at Microsoft.ManagementConsole.Internal.SnapInClient.CreateSnapIn(String assemblyName, String typeName)
   at Microsoft.ManagementConsole.Internal.ClassLibraryServices.Microsoft.ManagementConsole.Internal.IClassLibraryServices.CreateSnapIn(String assemblyName, String typeName)
   at Microsoft.ManagementConsole.Executive.SnapInInitializationOperation.OnStart()
   at Microsoft.ManagementConsole.Executive.RunningOperationsTable.EnqueueOperation(Operation operation)
   at Microsoft.ManagementConsole.Executive.StandAloneComponentData..ctor(SnapInRegistrationInfo info, Int32 bookkeepingId)
   at Microsoft.ManagementConsole.Advanced.FrameworkSnapInFactory.Microsoft.ManagementConsole.Advanced.ISnapInFactory.CreateSnapIn(Int32 bookkeepingId, String snapInKey, Object& snapIn)

 

We though it maybe the 7.15 LTSR CU7 iso we downloaded was corrupted so we downloaded the 7.15 LTSR CU6 and repeated the upgrade process by using a pervious snapshot state of 7.15 LTSR CU3 (before the 7.15 LTSR CU7 upgrade). However, the same message was displayed when Studio was launched.

 

We tried uncheck the option "Check for publisher’s certificate revocation" as described in CTX139325 and also updated the root certificated as described in CTX233206, but neither of them works.

 

OS is 08R2 and had performed all windows updates last week online (not from WSUS), any idea what I'm missing, grateful for any tips or hints.

 

Many thanks!

Link to comment

3 answers to this question

Recommended Posts

  • 0
6 hours ago, Raghavendra Kamath said:

Hi Grant Lui,

 

Try adding the environment variable "COMPLUS_version=v4.0.30319", perform the change via "System Properties\Advanced\Environment Variables".

 https://discussions.citrix.com/topic/405642-citrix-studio-crashing-when-loading-in-mmc-after-cu4-upgrade/ 

 

 

Regards,

Raghu

 

Hi Raghu,

 

Thank you very much for the tips.

 

We tried all versions from CU4 to CU7 and they all had same issue, the post you quoted suggests the issue begins from CU4 which seems a high match case to our senario.

 

We will kick-off the CU7 update again with the suggestion and let you know the outcome.

 

Once again thank you very much for tipping us since this issue is not widly documented in Citrix KBs nor Citrix is willing to offer us support because they said 2008R2 been EOL.

 

Grant

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...