Jump to content
Welcome to our new Citrix community!

Modify Netscaler configuration to point to new 7.15 environment from current 6.5 setup


Recommended Posts

We are in the process of migrating our current Citrix XenApp 6.5 environment to a new XenApp 7.15 environment. In addition we have a Netscaler VPX 200 device that services our external users currently. That is still pointed to the old 6.5 environment. I'd like to determine how and what to modify to change that VPX 200 to point to the new 7.15 setup instead.

 

The version of VPX that we are on is 12.0 63.21 nc. I've confirmed with support that this version of VPX is compatible with 7.15 as well as the newest workspace application available so I'm not wanting to upgrade the VPX quite yet but will after it gets pointed to the new environment.

 

When this portion is done, I also would like to utilize the Netscaler internally to load balance my storefront servers for internal use. We have a mixture of PC's and Wyse thin clients. The thin clients are too old unfortunately to point to an HTTPS storefront server so I have those setup with 2 of their own HTTP storefront servers and 2 HTTPS for my PC's. How do I incorporate those into the netscaler as well? Would it be at the same time as when I migrate the remote usage to it?

 

Sorry for all the questions, I do appreciate any help that people can give as it is production and I'm just being overly cautious. Thanks.

Link to comment
Share on other sites

Just the gateway migration:

 

In brief:  Depending on whether you are running your 6.5 and new 7.15 environment in parallel, the "easy" way to do this would be to

1) Let storefront aggregate your OLD 6.5 and NEW 7.15 environment.

2) Configure your gateway session polic(ies) to go from the existing WI (I assume) to the new Storefront Store which (has the 6.5 and 7.15 resources) aggregated.

3) Update the gateway for the STA's in the NEW 7.15 environment.  (And match the STA's the 7.15 is using.)

3) Update the storefront with the gateway settings.

 

Once your gateway is using storefront for OLD 6.5 and new 7.15 environment, you can then finish your migration off of 6.5 to 7.15 only and then deprecate your 6.16 integration on storefront.

 

Even if you want to switch from 6.5 to 7.15 only. The easy way is to switch from WI to STF for the 6.5 environment. Switch gateway to Storefront.  Then you just have to fix the storefront settings for 7.15 and update storefront and gateway settings for STA's.

 

Does this help or do you want more info?

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...