Jump to content
Welcome to our new Citrix community!
  • 1

Unable To Uninstall Citrix Workspace 2102


Jeffrey Bunce

Question

2 weeks ago, there were several updates that were installed in my laptop for CW 2102. "Something" happened on one of those update installations where it appears to not have completed successfully. I am  now presented with a pop-up stating "Please" wait while windows configures your Citrix Plug-in" and then I am presented with another popup where it is looking for the ICAWebWrapper.msi with a 'Browse' button to use to point to the proper location. When I try to uninstall CEW 2102, a Citrix Workspace popup is presented and just sits there "Initializing" and the progress bar goes nowhere. We use this app to connect to our VDI's so this is not happening! I am stuck!

Link to comment

8 answers to this question

Recommended Posts

  • 3

So I am not certain if this will work for everyone but this is what finally worked for me (also hello, this is my first post!):

I also was stuck with Citrix2109 and it was not functioning, but now I can use Citrix Workspace, it's version 2109.1 (which makes the difference, apparently, as it is working once again)

 

-Close all browsers (don't know if this matters but I'm superstitious and it seemed to help/not hurt)

-Start Command Prompt as Admin

-Navigate to _:\Program Files (x86)\Citrix\Citrix Workspace 2109\

-Run ReceiverCleanupUtility.exe with "/forceinstall" and possibly "/rca"

**With Command Prompt hanging (just like the Settings' Uninstall option it will hang forever): OPEN TASK MANAGER (or have it open from the start, doesn't matter)**

-STOP one of the Citrix Workspace applications (sorry I think it was the second one, but I think it was duplicated as well, cannot recall anymore)

-It will progress (hopefully) to the "Uninstalling .msi"

-You may have to stop more Citrix Workspace Applications but what you want is for CommandPrompt to RETURN YOU to the ...Citrix\Citrix Workspace 2109 folder (i.e. you have run the ReceiverCleanupUtility.exe once but nothing has happened)

-Run ReceiverCleanupUtility.exe again with "/forceinstall /rca" and hopefully it will actually remove Citrix the second time

 

Crossing my fingers for y'all!  This worked for me, I then installed the new version and I have Citrix working again, hope it works for some of y'all reading

 

Edit: Seems like it works?  Thanks Nathan!  Let's hope this doesn't happen again... I got nervous when I saw it was still 2109 (though .1)

  • Like 3
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...