Jump to content
Welcome to our new Citrix community!
  • 0

Printing from ICA-Sessions always misses first page


Alexander Spies

Question

If one specific user prints inside the ICA-session on the printer attached to his private/home device, the print-job always misses out on the first page. It doesn't matter which file format or type of print job. If you print stuff directly on the private/home device, it always prints all pages.

 

I've tried the following things in no particular order:

  • Switched between Citrix Universal Printer and the redirected Client printer and automatic usage of drivers - no change, first page misses.
  • Started print-jobs by selecting starting page '0' instead of '1' - no change, first page misses.
  • Tried switching between horizontal and vertical format - no change, first page misses.
  • Printed files to PDF first (Microsoft Print to PDF) - PDF looked fine. Printed PDF - first page misses.

 

User says this wasn't an issue with Windows 7 VDA including Personal vDisk.

 

Current setup:

Windows 10 Enterprise - Build 1909

VDA 7.1912 LTSR CU1

Pooled-Random with Citrix User Profile Management

Private device is a Windows OS as well.

Version of Citrix Receiver/Workspace App currently unknown << could this be the issue?

 

Anyone ever seen this behaviour before, especially after migrating users to Windows 10 or the VDA 1912 LTSR?

 

Best regards,
Alex

Link to comment

10 answers to this question

Recommended Posts

  • 0

Hi, 

Please install the latest version of Citrix Workspace app on the private device.

if "Citrix Universal Printer" Driver is used and "Heavyweight Compression" is on, please disable "Heavyweight Compression". If "Heavyweight Compression" is on then it could be the same issue as CVADHELP-15813. 

(Heavyweight Compression: https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/ica-policy-settings/printing-policy-settings/universal-printing-policy-settings.html)

 

Thanks.

-Fiel

Link to comment
  • 0

If the issue persists after update to latest CWA as suggested above, you may want to print with preview on client enabled to see if page one is making over to the client and getting lost there, is lost in spooling process on printing host.

 

Also, what application(s) and client-side printers/drivers exhibit this behavior?

 

-Gary Barton

 Citrix Systems

 

Link to comment
  • 0
On 2/20/2021 at 5:39 PM, Fiel Cabral said:

CVADHELP-15813

Thanks for your suggestions.

  • The currently installed version is the Citrix Workspace App 2002 (Director shows 20.2.0.25) - so it should work fine. Should we try the even newer version or the LTSR version of Workspace App?
  • Heavyweight Compression is not enabled in the Citrix Policies for this user-connection.
  • We tried different applications (Outlook, Word, PDF) and both the Citrix Universal Printer and the passed-through Canon-printer - it always misses the first page and works fine with second page onwards.
  • I checked a few settings inside "Printers & Scanners" for both devices and couldn't find anything out of the ordinary. The Citrix Universal Printer had 'Letter' instead of 'A4' as Paper format, but changing that didn't help either.

I'll try Gary's suggestion next with the preview on client. What are the next steps or suggestions, if the page is missing in the preview?

Edited by Alexander Spies
Link to comment
  • 0

The 'preview on the client' option shows all pages, including the first one. If you confirm it, the printer still prints only the second page - first page is still missing. It doesn't matter, that settings you change during the Preview-Wizard (Letter/A4, dual-sided or one-sided print, etc.). The first page is marked (blue frame) and still doesn't print.

 

I've found a workaround though, as the passed-through Microsoft Print to PDF (from...) works - it creates a PDF on the private device including all pages and if you print the local PDF-file, the first page works as expected.

 

So the passed-through PDF-Printer works, the Citrix Universal Printer and pass-through Canon-printer are not printing page #1. Canon could be due to a bad driver, but the Citrix Universal Printer should always work?! Any more suggestions, besides leaving the customer on the workaround?

Link to comment
  • 0

Hello Alexander for my understanding please amend,

1) like Gary highlighted our cpviewer.exe the client site helper application on the windows end-point displays/previews the print job correctly and the first page is still missing even when printing to the local attached printer using cpviewer ? 

if that is the case we need to rule out any respooling or injecting challenges of the spool job to local windows print spooler because the entire print job already arrived correctly on the windows end-point,the preview confirms that but who knows what the canon print provider expect now. Can you test with the server side policy of Universal printing EMF processing mode set to respool ?

 

2) I assume now that the auto created client printer (pass-through Canon-printer ) is created with our citrix emf upd driver as well.  If that is the case we would be highly interesting so see if the page is also missing when printing with the 3rd party canon driver installed and used on the host ? (requires installtion of the canon driver and reconfiguration or a reset to default printing citrix policies )

 

as a workaround for the time being I am certain that switching the Universal driver preference in our server side policy form EMF to XPS driver preference would hide the underlying issue but we wouldn't know the real culprint.....

 

BR

/ramzy

Link to comment
  • 0

Had same issue and a reinstall of Citrix Workspace for Windows resolved the first page not printing dilemma (went from ver 2202 to 2207).  Must uninstall older version, reboot and then install 2207.  An upgrade, without uninstall, did not work at first.

Link to comment
  • 0

Hi,

I have this issue also. When the users print at one location with a Canon printer i think, it works, but on the other location, with another printer brand, the first page is always missing. Only workaround ive found is to learn the users to save to PDF and then print from local.

 

Tried all other kind of workarounds - like uninstalling, rebooting, and installing latest version.

 

Im stuck - do anyone have any more suggestions what i can try?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...