Jump to content
Welcome to our new Citrix community!
  • 0

VDA 1912 CU2 random disconnects on server 2016


Matthias Eckerle1709157603

Question

We have identified random disconnects for active sessions on a server 2016 rds workload. The issue seems to come up on all sorts of citrix clients and versions.
Count for eventlog id: 12, source: rpm, message: connection broken unexpectedly for user Domain\user@domain.com) is above 100 on a workday for about 1000 active ccu sessions, According to the event log.
Not sure yet, if impact is real...waiting for citrix client logs right now.

These are the confirmed endpoint versions:

- Windows Receiver 4.9 CU6 / CU7

- Windows Workspace App 1912 CU2 / CU3

- Linux Receiver 13.7

- Linux Workspace App 2006
- Android Workspace App 2006


Sessions are mostly from local campus, so no adc gateway involved here. Applies to desktop sessions and seamless apps, so not a difference here either.
Is this a known issue on this version? Anyone tackling similar issue?

Link to comment
  • Answers 77
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 0

I can confirm the problem. I can confirm the issue with 1912/1912CU1/1912CU2 and the latest CR 2012. 

 

I sent CDF traces to Citrix already and I'm waiting for analysis. 


It seems that the issue is already described here: CTX286701. I know you wrote about event id 12. I see both event ids (10 and 12). The described workarounds don't work for me. 

 

If you have some news, please tell us :-) 

Link to comment
  • 0

Hi Patrick,

 

thank you for your update. I also see both event IDs, but for me ID12 seems to mark the final issue regarding disconnected sessions. 
I can confirm, the issue is present in VDA release 1912CU1/1912CU2. We also rolled out the registry key mentioned in CU2 fixed issues (CVADHELP-15122).
But newly reports indicate that this does will not help. Session reliability is still active in this environment....we are not willing to change this.
 

If you have some news, please tell us :-) 

Link to comment
  • 0
9 hours ago, Patrick Matula said:

Please open a case Sebastian :-) In the best case, try to get CDF and network traces in advance. They will need that. 

Good morning, 

I will do but we are trying today some more, we have deleted the MTUDiscovery Reg from our Servers as having issues on a Laptop with freezing Desktop when trying to use the Webcam. Without MTU Discovery this is running like charm. I have also implemented the RegKey from CVADHELP-15122 this morning, will be rolled out tomorrow, so we can see any improvements on Monday maybe. Session Reliability is still switched on.

Link to comment
  • 0
14 hours ago, Matthias Eckerle1709157603 said:

Update:

We are planning to rollout registry fix CVADHELP-15122 next week thursday, baked into master image.
But I’m still not sure if this applies to session reliability or keep alive only. Could not get on call with citrix support yet...hope on Monday!

We definitely do not see this issues on MCS-based workloads nor persistent VDAs.

Wee see this issue also on non persistent VDAs. 

Link to comment
  • 0

Good morning,

 

with deleted MTU Discovery and settled MTU 1400 in ica file on the Storefront it’s much better now but still not perfect. 
Still having the RPM entries and still some users experiencing disconnects.

As of today we have implemented the CVADHELP-15122 regkey to our VDAs. Will keep track today.

I think the biggest issue is ipv6 connections from the clients tunneling ipv4 with dslite and fragmenting packages.

 

best regards

Sebastian

Link to comment
  • 0

I investigated the issue more and talked to end-users. 

One very interesting thing: Even normal disconnects (because a user wants to disconnect) _can_ generate the rpm error message. 

That seems to be the reason why the uploaded CDF/network traces were not very useful for Citrix support.

 

Additionally to cdf/network traces you also have to confirm with the enduser that he/she experienced a "real random session disconnect". 

Link to comment
  • 0

We are having the same issues with a NetScaler 13.0 58.32.nc and VDA version 1912.0.1000.24525 (CU1 I think) on Windows Server 2019. 

 

We have 6 servers in the farm, and we noticed that sometimes everyone (or nearly everyone) on a particular server will get disconnected and the rpm event ID 10 warnings show up for all the discontented sessions. The users can then reconnect without an issue. Hopefully someone comes up with a solution. I am considering moving off of the LTSR and installing a newer version. Has anyone tried that yet?

Link to comment
  • 0
7 hours ago, Roel Niesen said:

Hello,

 

Is see this problem to on windows server 2019.

User doesn't see his session and have to wait for some time to reconnect.

 

Is there a solution already?

 

Case #80460490

 

 

 

Why has the user to wait? What happens if the user tries to reconnect immediately?

Link to comment
  • 0

Hello,

 

When the rpm error oocures, it takes some minutes before a new conenction can been made.

When the problem happes, all apps are gone (published apps) and when the user click on a new app, it will not work imediatly.

 

Then when the user can make a new connention, citrix takes a loong time to reconnect.  We see that also on an normal reconnect.

If I'm right this has some to do with the policy's?

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...