Jump to content
Welcome to our new Citrix community!

Refresh login schema


Roy Smith

Recommended Posts

Hi

 

I am updating a login schema and changed the assistive text for the username box. However, when I browse to the authentication server, the new text is not displayed. I have confirmed the text is correct in the actual XML files on both cluster members. I assume the schema file is being cached on the ADC. I seem to recall there was a method of clearing the cache. Is this possible? Or is there somewhere else to refresh the web server without restarting either cluster member?

 

Thanks in advance

Roy

Link to comment
Share on other sites

1) clearing the cache on ADC:  GUI:  Optimizations > Integrated Caching, go to view cache objects in right pane and then you can view objects and flush cache (and maybe disable caching temporarily) if you are want to avoid it.  Also be sure your browser isn't the thing caching.

 

2) It might not be the cache though.

EDIT:  I did this from memory. IF you need a clearer example with screenshots of below see this thread:  https://discussions.citrix.com/topic/408275-edit-loginschema-but-wrong-result/  And it notes which version of firmware we saw an issue with the editor.  May not be  your exact issue, but its really easy to not point to file expected in gui...

END EDIT.

 

First, There are two directories where loginschemas are stored:  (I'm going to mess up the case, so check on real system for actual case-sensitive paths)
/nsconfig/loginschema  (which I will refer to as Schema1)

and

/nsconfig/loginschema/LoginSchema (which I will refer to as Schema2)

 

Usually the original schema's are in the Schema2 directory and any custom Schemas you create are in the Schema1 path so that you can restore the original if needed.

 

Second, when you use the gui to set the loginschema action to the schema name and file path, the gui makes it easy to miss this step.

If when you create the action, you make the new schema from an original, the gui automatically moves it to the Schema1 directory as a custom. But unless you hit "SELECT" on the gui editor, your action may still be pointing to the default schema and not the one you were working on.  Meaning, if you create new schemaaction, point to original schema file and create edit, the gui creates a new_schema file in the Schema1 directory and even if you HIGHLIGHT It and click OK you are still pointing to the original file and not the one you just edited. You have to choose the edited schema file and CLICK "SELECT" in the right-hand pane next to EDIT to point to the file and not the original....

 

Basically, make sure your schema action is pointing to the expected filename in the Schema1 directory /nsconfig/loginschema/<customschemaname> and not still pointing to the original file in the Schema2 directory:  /nsconfig/loginschema/LoginSchema/<originalfile>

 

AND make sure you actually edited the file you thought and loaded it to the right directory.

 

There was a firmware version that had some issues with the gui editor and they had to be edited locally as well. But I'd have to go find my prior post on it for more details.

---

IF you have fully check the file and file location and so that isn't a problem then, its something else.  But it so easy to not be on the right instance of the file, i always start with reconfirming that.

 

Edited by Rhonda Rowland
Added notes.
Link to comment
Share on other sites

We don't have integrated caching enabled. I also checked it was using the correct file and there is only one copy on each cluster member.

 

So, I went back in to to check the schema in the GUI. I chose to edit the login schema, selected the login schema that was already selected and saved the configuration, without actually making any changes. When I browsed to the url the page was changed with the new text. Very strange issue but as we don't update the schema very often, I'll take it as a win.

 

Thanks for the help

Roy

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...