Jump to content
Welcome to our new Citrix community!

Missing NT SERVICE\CitrixConfigurationReplication


Recommended Posts

Hello together, 

 

I have installed two storefront servers today. Now when I try to join the second storefront system in a server group I can't. I have event id like 2850, 2203 and 2201.

 

Furthermore, in the local admin group of second storefront I miss the following account:

 

NT SERVICE\CitrixConfigurationReplication

 

Anybody have an idea why or it exist a solution for that issue ?

 

Kind regards

Giuseppe

Link to comment
Share on other sites

Note: "NT SERVICE\CitrixConfigurationReplication" is not an account, it is a per service service identifier.

See: https://docs.microsoft.com/en-us/sql/relational-databases/security/using-service-sids-to-grant-permissions-to-services-in-sql-server?view=sql-server-ver15 for a discussion on using per-service sids for authorization purposes.

Link to comment
Share on other sites

Ok Thanks.

 

But I can't add the second StoreFront to an servergroup. 

 

An error occurred while executing the following command: 'Add-DSClusterMember'
The access was denied.
In C: \ Program Files \ Citrix \ Receiver StoreFront \ Management \ Cmdlets \ ConfigurationReplicationModule.psm1: 146 characters: 5
+ Clear-DSConfigurationReplicationClusterMemberCache
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~
The access was denied.    # <---- I don't know why here is access denied. My Account is a full domain administrator and also on each system a local administrator. #

Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces.Exceptions.PowerShellExecutionException, Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces, Version = 3.22.0.0, Culture = neutral, PublicKeyToken = e8b77d454fa2a856
An error occurred while executing the following command: 'Add-DSClusterMember'
The access was denied.
In C: \ Program Files \ Citrix \ Receiver StoreFront \ Management \ Cmdlets \ ConfigurationReplicationModule.psm1: 146 characters: 5
+ Clear-DSConfigurationReplicationClusterMemberCache
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~


System.Management.Automation.ActionPreferenceStopException, System.Management.Automation, Version = 3.0.0.0, Culture = neutral, PublicKeyToken = 31bf3856ad364e35
The executed command was terminated because the setting variable "ErrorActionPreference" or a general parameter is set to "Stop": Access was denied ..
System.Management.Automation.Interpreter.InterpretedFrameInfo: System.Management.Automation.Interpreter.InterpretedFrameInfo []
   at System.Management.Automation.Runspaces.PipelineBase.Invoke (IEnumerable input)
   at Citrix.DeliveryServices.PowerShell.Command.Runner.PowerShellCommandRunner.InvokeCommand (IPowerShellCommand command, Command powerShellCommand)
   at Citrix.DeliveryServices.PowerShell.Command.Runner.PowerShellCommandRunner.RunCommand (IPowerShellCommand command)

Link to comment
Share on other sites

Hello,

I encountered the same issue with Storefront 1912 LTSR CU2

I tried a lot of things without success.

what worked for me :

-Uninstall Storefront on the two servers and reboot

-Install Storefront 1912 LTSR CU1 on the two servers and reboot

-Configure Storefront again

-Add the second StoreFront to servergroup with success

-Update to Storefront 1912 LTSR CU2

 

Regards,

Nicolas

Link to comment
Share on other sites

  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...