Jump to content
Welcome to our new Citrix community!
  • 0

VDA 2012 Silent install with WEM


MArkus Wehr

Question

Hi,

 

I wanted to use the silent install feature with the standalone installer VDAServerSetup_2012.exe.

I use parameters to exclude UPM and include WEM. 

/includeadditional "Workspace Environment Management" /exclude "Citrix User Profile Manager","Citrix User Profile Manager WMI Plugin"

 

It does not install WEM but installs UPM.

In the "XenDesktop Installation.log" I see no error - the command line is listed correctly.

If I use the same installer manually the result is as expected with WEM installed and UPM not.

 

anyone tried this?

best regards

 

Markus

Link to comment

11 answers to this question

Recommended Posts

  • 0

 

 

VDAServerSetup_2012.exe /quiet  /noreboot  /components vda /masterimage   /controllers "dc01 dc02"   /wem_server wem-server.local  /logpath $logpath  /includeadditional "Workspace Environment Management"  /exclude "Citrix User Profile Manager", "Citrix User Profile Manager WMI Plugin"  /disableexperiencemetrics  /enable_hdx_ports  /enable_hdx_udp_ports

 

Actually i use powershell and variables. But that works with all parameters. I can see them in the log file correctly.

 

complete exclude:

 

"Citrix User Profile Manager", "Citrix User Profile Manager WMI Plugin", "Citrix Telemetry Service",

 "Citrix Personalization for App-V - VDA","Citrix Supportability Tools","Citrix Files for Windows", "Citrix Files for Outlook", 

"User personalization layer"

Link to comment
  • 0
2 hours ago, MArkus Wehr said:

 

 

VDAServerSetup_2012.exe /quiet  /noreboot  /components vda /masterimage   /controllers "dc01 dc02"   /wem_server wem-server.local  /logpath $logpath  /includeadditional "Workspace Environment Management"  /exclude "Citrix User Profile Manager", "Citrix User Profile Manager WMI Plugin"  /disableexperiencemetrics  /enable_hdx_ports  /enable_hdx_udp_ports

 

Actually i use powershell and variables. But that works with all parameters. I can see them in the log file correctly.

 

complete exclude:

 

"Citrix User Profile Manager", "Citrix User Profile Manager WMI Plugin", "Citrix Telemetry Service",

 "Citrix Personalization for App-V - VDA","Citrix Supportability Tools","Citrix Files for Windows", "Citrix Files for Outlook", 

"User personalization layer"

The parameters are almost the same as the ones I use, I think it's a bug in the installer.

Link to comment
  • 0

I have a customer who is also experiencing strange issues with the VDA workstation installer, specifically with the MCSIO driver install.

 

This will install the MCSIO driver:
/components vda /install_mcsio_driver /mastermcsimage /enable_real_time_transport /enable_hdx_ports /enable_hdx_udp_ports /enable_remote_assistance /disableexperiencemetrics /noreboot /quiet /exclude "Citrix Telemetry Service" /logpath "C:\InstallLogs"

 

This will not install the MCSIO driver:
/components vda /install_mcsio_driver /mastermcsimage /enable_real_time_transport /enable_hdx_ports /enable_hdx_udp_ports /enable_remote_assistance /disableexperiencemetrics /noreboot /quiet /includeadditional "User personalization layer" /exclude "Citrix Telemetry Service" /logpath "C:\InstallLogs"

It looks like if the /includeadditional parameter is specified, the MCSIO driver is not installed.

It looks like there are numerous issues with this version. My customer has an open support case about this issue.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...