Jump to content
Welcome to our new Citrix community!
  • 0

Group Policy SDK & Citrix Cloud


Rooney Smith1709162255

Question

I'm working with the Citrix Cloud Control Plane and using the Remote PowerShell SDK.

I want to access CVADS Farm Policies but have questions as getting strange behaviour.

 

All examples I can find to do this follow this or a similar format which seems to be the older on-premise way of doing things.

 

New-PSDrive Site -PSProvider CitrixGroupPolicy -Root \ -Controller localhost

 

As I'm working in Citrix Cloud I change it to

New-PSDrive Site -PSProvider CitrixGroupPolicy -Root \ -Controller <subscriptionID>.xendesktop.net:443

 

This seems to work but I get prompted to authenticate 2 or 3 times (only expected the once). Once when I run the above command and then for the next one or 2 commands that follow.  Doesn't matter what the command is but anything that tries to access policies I get prompted, type in my credentials and the command succeeds. Then the authentication prompts go away and all seems to work as expected.

 

If I authenticate first (using Get-XDAuthentication) I still get the prompts. Its almost as if the "citrix.common.grouppolicy" module uses a separate autentication model.

 

What am I doing wrong?

 

Also how do I support other authentication methods to Citrix Cloud (e.g. API bearer token) in the above New-PSDrive command ?

 

Thanks in advance

 

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...