Jump to content
Welcome to our new Citrix community!

ConfigAudit Polling is Already In Progress


Recommended Posts

I'm trying to use 'Networks>Configuration Audit' on ADM 13.0 71.40 to compare templates against running configurations, but keep running into a situation where polling get's 'stuck', and I can't run audit jobs on instances, and get the following error when I try:

image.thumb.png.303c7b18334f5f8714ea7328f694cc45.png

Does anyone know of a way to 'restart' the configaudit polling service, and/or clear out these pending jobs? I've run into this on previous versions as well, and eventually it will clear up on its own, but it makes the feature unusable to not have a reliable way to audit on a schedule or on demand.

Link to comment
Share on other sites

Yes, this bug seems to have persisted since 12.1, and appears to be specific to using audit templates that use variables. 

 

Hopefully someone from Citrix can comment on how to 'restart' the polling engine and/or clear queued polling jobs as this is the last piece of a continuous integration framework that I've been working on for ADCs.

Link to comment
Share on other sites

On 1/22/2021 at 3:11 PM, Kenneth Baldwin1709162447 said:

Yes, this bug seems to have persisted since 12.1, and appears to be specific to using audit templates that use variables. 

 

Hopefully someone from Citrix can comment on how to 'restart' the polling engine and/or clear queued polling jobs as this is the last piece of a continuous integration framework that I've been working on for ADCs.

 

This won't happen here. It will get fixed if "someone" creates a support ticket on this issue.

Link to comment
Share on other sites

  • 3 weeks later...
On 1/25/2021 at 8:43 AM, Johannes Norz said:

Support takes time :64_zipper_mouth:

Yes, it took more time than it took me to figure it out on my own, which doesn't do me much good :32_expressionless: (wasted a lot of time generating and uploading support bundles).

 

Anyways, I thought I'd share the fix in case anyone else is dealing with the same issue. 

 

After digging through the logs I found that the issue is being caused by the ADC command policy I'm using to restrict the ADM device profile account, which is this:

 

(scp.+)|(diff.+)|(save.+)|(show.+)|(stat.+)|(add snmp.+)|(rm snmp.+)

 

Apparently the audit polling is getting hung up on trying to drop into shell, per the following errors in /var/mps/log/mpsinventory.log

 

[Error] [Inventory[#25]] Command failed, instance is not reachable with error on #.#.#.#: -43

[Debug] [Inventory[#25]] Result of "shell" command on #.#.#.#

 shell

ERROR: Not authorized to execute this command [shell]

 

After adding shell to my command policy, it works within a minute:

(scp.+)|(diff.+)|(save.+)|(show.+)|(stat.+)|(add snmp.+)|(rm snmp.+)|(unset.+)|(shell)

 

However, I don't want to give ADM shell access since it essentially provides root access to the system, and so I'm asking Citrix to explain why ADM waits 20 minutes for shell to get a difference of the configurations.. it eventually works after all, it just takes 20 minutes of waiting for the process to timeout.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...