Jump to content
Welcome to our new Citrix community!
  • 0

ELM 2011 add version fails with "Certificate doesn't contain private key Exception"


Egor Nikishin

Question

Hello everyone!

I'm trying to build a POC App Layering infrastructure.  Successfully built 2009 version, and everyting was working fine until i updated 2009 to 2011 build. Update completed successfully, but when i tried to add version to any of my OS layers it failed with error: 

An unexpected system error occurred.  Retry the operation or contact technical support.
Exception Message: Certificate doesn't contain private key Exception Details: <No Details>

 

Connector to my Hyper-V server looks fine, app layering is able to communicate with Hyper-V host, and see machines. I tried to reinstall agent on Hyper-V server with same result.

Any help would be appreciated!

Error.jpg

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...