Jump to content
Welcome to our new Citrix community!
  • 0

XS 8.0 after reboot local SR not able to attach


JUERGEN BLESSING

Question

Hi,

 

after a long time XS 8 up and running, the local SR is not being able to mount anymore after a reboot. Still not clear, what caused this problem,

 

Working though https://support.citrix.com/article/CTX116017, which explains the situation a bit, does not help. The different IDs seem not to match

Maybe the sr-forget was also not the best way to continoue troubleshooting...

 

What we have:

- XS 8.0 boots, but has now no local SR.

- The SR was on /dev/sda

- pvscan does not show any information

 

How can this (existing) SR be imported or activated? The consistency check of the underlying RAID showd no defects.

Working with the aboce TID, it says the recreate with

pvcreate --restorefile /root/lvm-backup/VG_XenStorage-<sr uuid> --uuid <PV uuid from backup file in step 1> /dev/<device path>

Which one is the PV uuid?

 

The backup file looks like:

VG_XenStorage-fd85428a-1681-8896-a15a-8adb7996c8bd {
    id = "3GC0cI-upJ0-dzcO-aqMM-hpIl-OkPi-Mb8UZQ"
    seqno = 2018529
    format = "lvm2"            # informational
    status = ["RESIZEABLE", "READ", "WRITE"]
    flags = []
    extent_size = 8192        # 4 Megabytes
    max_lv = 0
    max_pv = 0
    metadata_copies = 0

    physical_volumes {

        pv0 {
            id = "kEUUVO-r6Ox-dHVe-zzjP-fpif-imZB-TJBamv"
            device = "/dev/sda"    # Hint only

            status = ["ALLOCATABLE"]
            flags = []
            dev_size = 4684251136    # 2.18127 Terabytes
            pe_start = 22528
            pe_count = 571805    # 2.18126 Terabytes
        }
    }

 

Any hint/help appreciated!

Thanks!

 

 

Link to comment

6 answers to this question

Recommended Posts

  • 0

It is a separate drive, exposed by the Raid Controller, and yes, it is LVM

the volume is not active.

 

xe sr-probe type=lvmohba \
>

Error code: SR_BACKEND_FAILURE_107
Error parameters: , The SCSIid parameter is missing or incorrect, <?xml version="1.0" ?>
<Devlist>
<BlockDevice>
<path>/dev/sda</path>
<numpaths>1</numpaths>
<SCSIid>3600605b00695b4c020a0c10d6a49d6f1</SCSIid>
<vendor>LSI</vendor>
<serial>00f1d6496a0dc1a020c0b49506b00506</serial>
<size>2398336581632</size>
<adapter>0</adapter>
<channel>2</channel>
<id>0</id>
<lun>0</lun>
<hba>megaraid_sas</hba>
</BlockDevice>

 

so, the block device is there.

The question is, which commands are non-destructive, to tell XS to uses this device again as a local SR?

 

pbd-create host-uuid=uuid_of_host sr-uuid=uuid_of_sr [device-config:key=corresponding_value]

will this just add it again or will it delete/format it?

Link to comment
  • 0

Mark,

 

the pvscan does not show anything.

I tried it with

 

xe sr-introduce uuid=fd85428a-1681-8896-a15a-8adb7996c8bd type=lvm name-label="Local storage" content-type=user

 

xe pbd-create sr-uuid=fd85428a-1681-8896-a15a-8adb7996c8bd device-config:device=/dev/disk/by-id/scsi-3600605b00695b4c020a0c10d6a49d6f1 host-uuid=e66a283f-37ac-4f67-b3dd-0ec1bb0b19d8

 

 xe pbd-plug uuid=ac2fac4f-d31e-6642-72b6-a9f997a368c2
Error code: SR_BACKEND_FAILURE_47
Error parameters: , The SR is not available [opterr=no such volume group: VG_XenStorage-fd85428a-1681-8896-a15a-8adb7996c8bd],

 

What else can I try?

 

- Is there any chance to copy the data to anaother host or to an nfs storage pool attached to this XS and then export the Vms?

 

Edited by JBlessing
add. question
Link to comment
  • 0

Tobias,

I wished I would have seen this earlier, deleting the state.db and letting XS recreate it would have been the last effort for me, but I had reinstalled XS already again and was doing restores from backup.

Unfortunately, we dont know whether this would have done the trickfor future reference, but its definmitely a try for others if all other solutions fail.

 

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...