Jump to content
Welcome to our new Citrix community!

100 mbps network speed problem "Cannot advertise speed 1000"


Recommended Posts

I tried to provide the solution in the link below, but after the server restarted, you lost network access. I rolled back the operations in the same way again. can you help me

https://support.citrix.com/article/CTX117568

Xenserver 8 and 8.2

```
# ethtool -s eth3 speed 1000
Cannot advertise speed 1000

Settings for eth3:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Supported pause frame use: Symmetric
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: on (auto)
    Supports Wake-on: pumbg
    Wake-on: d
    Current message level: 0x00000007 (7)
                   drv probe link
    Link detected: yes
```

I'm running the command below, but access to the server is going and not coming. The document is old but how can I fix this problem.
ethtool -s eth3 speed 1000 duplex full autoneg off

Link to comment
Share on other sites

This is about a VPX running on Citrix Hypervisor (formerly called Xen Server)? If this is true, you don't need to set network speed. Instead, all interfaces have to be of type "XEN Interface". Speed is controlled by your hypervisor and you should not change settings. Interfaces always show as 1 GBt (1/1, 1/2, ...) however, network speed won't get overallocated.

 

Greetings from sunny but chilly Austria

 

Johannes Norz

CTA, CCI, CCE-N

https://blog.norz.at

https://wonderkitchen.network

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...