Jump to content
Welcome to our new Citrix community!
  • 0

UPL and WSL2


Eric Siemiatkaska

Question

I'm new to the forums, and Citrix in general, so I'd like to apologize in advance if this isn't correct forum for this question. That said, I was wondering if User Layering is compatible with WSL2. I am running Citrix Virtual Apps and Desktops 7 2009 on Windows 10 v2004 with no remaining updates listed in Windows Update. 

 

When I enable User Layering all WSL repos throw the following error when trying to open them for the first time... 

 

image.thumb.png.259ef6b654c12c70667d9fe01925251e.png

 

This error only occurs when the default WSL version is set to 2. If I change the default version to 1, the repos open just fine. If I disable User Layering I can then open the repos using WSL2 without an error.

Link to comment

12 answers to this question

Recommended Posts

  • 0

This is the right place.  That said i have never heard of anyone using wsl with an app layered desktop so I don't know if what you are seeing is normal or how to approach it.  BTW are you using app layering for your image and the full user layer or the user personalization layer installed with the VDA?

 

I was not able to determine if WSL uses a filter driver and what type it might be.  If it does there may be an adverse reaction there that changing the elevation of one or the other of the filters could help.

 

I will ask if anyone in support or engineering has any experience with wsl but first i need to know the answer of which version you are using of the user layer.

Link to comment
  • 0
On 12/7/2020 at 1:46 PM, Raymond Colon said:

For reference. We do not support WSL2, but do WSL1. We do have WSL2 noted as a candidate for testing and approval, though not in the near future.

 

According to this article, the personal vDisk has been deprecated and we should be using the user personalization layer feature to handle user persistence. However, since UPL doesn't support WSL2 what should I use?

Link to comment
  • 0

Currently we do not support WSL2 with user layers or UPL, however we are working to address some issues that relate to general virtualization support when user layers are enabled. These enhancements may permit us to support WSL2 in the future, however we cannot confirm when support will be available at this time.

 

As was previously noted, WSL1 is currently supported with user layers and can be used within the image.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...