Jump to content
Welcome to our new Citrix community!

Citrix session hangs for an extended period with the DUO Radius server


Osvaldo Ramirez

Recommended Posts

Hi folks

 

I have a client with Netscaler VPX Version 10.5 and the DUO Radius server as the main authentication method


Users can log in for the first successful login attempt, but when users log in for a long period of time or log out and try to reconnect, users experience a session hang in citrix studio, users show the following error message from the citrix website "cannot complete your request" and from the Citrix Receiver application "Your applications are not available at this time. Please try again in a few minutes or contact their technical support with the following information. There was an error communicating with the Store "

and set the timeout (seconds) to 60 for Radius policy in the netscaler

to solve this problem I have to close the session of the users that hangs from citrix studio and reset the citrix receiver to the factory for the users

Any ideas to solve this problem?

 

thanks for your help!

 

 

cannot complete your request.png

error_to_contact_to_store.png

Link to comment
Share on other sites

  • 2 weeks later...

Hi folks

 

My problem has been solved, I realized that the problem was not with the Radius DUO server, but it was residing on the netscaler side specifically in the integration of the NS and SF for the virtual server of the Netscaler gateway, for some strange reason domain was not complete and there was only one CN,
the problem was solved by adding the full Active Directory domain in Citrix Gateway> Virtual Server> Session Policy> Edit Profile> Published Application> Single sign-on domain, like this for each citrix policy.

 

Solucion_Radius.thumb.png.e43fefc54b2ea0b1d13e4cccd0742615.png

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...