Jump to content
Welcome to our new Citrix community!
  • 0

This version of Citrix Workspace does not support selected encryption. - for one user.


Andrew Snodgrass

Question

We have a client that uses Citrix Workspace on all of their machines (~8) to access patient records, and one machine occasionally has the following error:

"Citrix Workspace App ERROR

This version of Citrix Workspace does not support selected encryption. Please contact your administrator."

 

I have followed the typical guides (like the ones below and more), but only recreating the local PC profile is able to fix the issue for about a month at a time ("recreating" meaning renaming the user file path and removing the user from ProfileList in Reg, then logging back in with that profile).

https://support.citrix.com/article/CTX133536

https://discussions.citrix.com/topic/394494-receiver-49-this-version-of-citrix-receiver-does-not-support-selected-encryption/

 

More Notes:

- It only happens on one profile. Logging into the same machine with a different user will allow Citrix to work fine.

- Citrix Workspace is running the same version as all other machines.

- This domain account does not have this issue on other machines.

- When initiating a connection, if it is going to work, the loading window starts filling the progress bar immediately.  If it is not going to work, the progress window sits idle until the error message pops up.

- I've attempted reinstalling Citrix Workspace multiple times, using the provided cleanup utility and manually removing AppData and reg entries. This made no difference.

 

I'm either looking for a permanent fix or a better solution than requiring user file transfer and setting up user applications/licensing each time it breaks. 

Link to comment

3 answers to this question

Recommended Posts

  • 0

UPDATE:

I contacted the provider a month ago, and they sent me a document and a tool for removing registry entries.  I followed their suggestion and it has been working as expected since then. 

 

From the document: "Ensure that RemoteScan is not installed.  RemoteScan is the primary (if not the only) cause for these Encryption Errors."

Summary of procedure:

  1. Uninstall RemoteScan.
  2. Reboot.
  3. Uninstall Citrix.
  4. Remove all Citrix entries from the Registry.
  5. Reboot.
  6. Reinstall Citrix.
  • Like 1
Link to comment
  • 0

I tried everything for weeks to fix this issue. Right down to the registry. In the end I had to create a new windows user on the pc, not the remote profile. Then I got a virtual driver error, I uninstalled it and ran the registry cleanup, then reinstalled the version I last used and it worked fine. I did all these steps a dozen times on my computer with my main account, it only worked when I made a new Windows user and did those steps.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...