Jump to content
Welcome to our new Citrix community!
  • 0

KB4586793 2020-11 Cumulative Update for Windows Server 2019 (cvhdmp.sys Stop Error)


Kevin Halstead1709158370

Question

HI,

 

We are attempting to install KB4586793 2020-11 Cumulative update for Windows Server 2019 on our VDisk. 

 

The machine has two Nics, one for the PVS network which is boots the Vdisk off and one for the Management network.

 

All is fine until we come to install this update, reboots. Then get a stop BSOD error about cvhdmp.sys.  It looks like it doesn't pick up management IP address.  I've had to revert back to an old image.

 

I've tried several times now. I've installed the latest Target Device PVS software. CU6.

 

Any other pointers apart from reversing the image or is this a known issue with this update?

 

Thanks.

 

 

 

Link to comment

2 answers to this question

Recommended Posts

  • 0

Having same issue and have been since the 10-2020 Cumulative Updates as well. New PVS maintenance version apply the Windows Updates, reboot and when it gets to the PVS boot screen where it displays server and client IP addresses the VM crashes back to the boot screen, I end up with 0xc000000f: A Required device isn't connected or cant' be accessed after the third reboot.

 

I've tried also several times, no matter what I install, once I install the Windows Cumulative Updates it crashes after reboot.

 

I've tried 1) Upgrading PVS Target Device Software to latest 7.15 LTSR, after updates - Failed to boot, 2) Upgrading VMware Tools to latest release, after updates - Failed to boot.

 

Running: Server 2016, VMware environment, 7.15 LTSR PVS and VDA. One Nic VMXNet3.

Link to comment
  • 0

I was able to resolve this issue for myself by reverse imaging my vdisk using the BCDEDIT method (https://www.carlstalhood.com/pvs-update-vdisk/#reverseimagebcdedit).

 

After booting into the image, and running the now 2020-12 cumulative updates. I experienced the same issue where the VHDX would no longer boot after the updates were applied. I booted into the host OS image, then mounted the VHDX where I ran a CHKDSK which discovered some issues with my VDISK. It ran the repair, then I rebooted again back into the BCD VHDX where on reboot it ran another subsequent Startup Repair. At that point, the VM fully booted and finished the update cycle. I rebooted a few more times to make sure it was working.

 

Then copied back the VHDX to my PVS store and Imported the new image. Set my maintenance device to boot from the new VDISK and it has been working since then.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...