Jump to content
Welcome to our new Citrix community!

LDAP binding problem in a "XenApp and XenDesktop" wizard


Giorgi Gogoladze

Recommended Posts

Hello Everybody

 

I am using "XenApp and XenDesktop" wizard for creating secure external access in an ADC.

Having an issue during "Authentication" step in a wizard when I'm trying to bind a domain server (tested on ver.13.0.64.35 & 13.0.67.39).

For clarification, if I have already created LDAP server in advance with the name, it is not even shown in the list of preconfigured LDAP servers in a wizard, to bind. But if I create mentioned server with the IP address (no matter whether in advance or in a wizard), then everything is OK and I can accomplish every step in a wizard successfully.

Any ideas would be highly appreciated.

 

Thanks in advance

Link to comment
Share on other sites

If you pre-created a lb vserver of type TCP:389 or SSL_TCP:636 it should show up in the list of vservers.  confirm your ldap vserver settings.

Share your vserver protocol/port to see if the wizard is skipping a listing it should be showing you.

 

Bad naming convention in my example and I described the wrong thing. This is fixed.

The existing server option shows you any existing ldap authentication actions that you've created.  (Precreate this first and use it in the wizard)

Pre-create the authentication action (server) and then the wizard will use this action to construct the policy on your behalf.

Inside that authenticaiton action you can then point to your ldap authentication lb vserver by IP (VIP) or use the other existing entry.

 

 

 

If not, you can use the wizard to create a temporary policy and swap in the real policy after the fact on the vpn vserver.  The wizards are sometimes limited in their flexibility.

It's actually much easier to do the XA/XD/CVAD setup inside the Universal gateway wizard or to just configure the session policy manually without the wizard on the vpn vserver afterwards.

 

 

Edited by Rhonda Rowland
corrected wrong info
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...