Jump to content
Welcome to our new Citrix community!
  • 0

Xen push storage data through management


Piotr Sajdak

Question

Hi. I'm quite new to Xen. I'm using XCP-ng in my homelab. Overlook:

I have 2 HP servers which both of them have two 1gb NIC's. I wanted to try some VM migration and because my switch supports only FastEthernet i figured out i can fix them in that way:

NIC0 <----> Switch <----> NIC0 (management adresses in 192.168.43.0/24)

NIC1 <----> NIC1 (storage network with adress pool 192.168.0.0/24)

 

So, management works ok no problems but main idea was to move VM's through network1 which contains 1gbps NICs. So i created external network1 with nic1 and nic1 included and tried to copy VM from host1 to host2. I had feeling it takes too long so i checked performance tab with networking and it's visible whole traffic goes through NIC0 to NIC0 (management network). I see it also in "ifconfig" directly on hosts that's using eth0(management).

I tried to do that when they were not in a pool, and later when they were in a pool and always go same way
Can it be becuase storage network gonna work only if i will have some shared disks(and not working while copying from local to local)?

I tried even deploying DVSC but then i feel like blind and also didn't find a way to use that NIC1 interfaces.

Link to comment

11 answers to this question

Recommended Posts

  • 0

Yeah i choose there network which i created for storage there is even notification NOT to use management network. Whole xen install is almost fresh. Configured is only this what i written. There is 1 random vm with some default linux install just to be.

 

So i choose Network1 which contains NIC1 in both servers and im copying from local storage to local storage(can be this a source of problem? In fact my "storage network" contains only 2 ethernet cards nothing more)

 

I thought maybe there is misunderdtanding with some aliases but i checked size and time of copying and it exacts to FastEthernet. 

 

Bothe network0 and network1 are created by option external network.

 I tried create cross-server network but it allows to use only network0(management)

Link to comment
  • 0

I dont understand your answer. If i have both NICs connected to next both NICs just one connection has switch between why i shouldn't be able to choose which way send data? Sounds like not expected way. If there is network destined to sending storage containing data why it forces to send it through management network if both networks goes same destination?

 

How then i can make usage of that 1gb cards to move VMs instead of sending them through FE-only switch?

Link to comment
  • 0
5 hours ago, Piotr Sajdak said:

I think i might have found a solution but didnt have time to test it. And is solution also for HA cluster with 2 nodes. Answer can be HA lizard.

HA Lizard is a great solution for a two-node, HA cluster, but that seems surprising it should affect the interface used for the data transfer. Also, I just realized that you are using XCP-ng, which is not exactly the same product as Citrix XenServer/Citrix Hypervisor! Ypu should instead take your issue to their forum at https://xcp-ng.org/forum/

 

-=Tobias

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...