Jump to content
Welcome to our new Citrix community!
  • 0

Can't see Client C drive in published Remote Desktop Session


Pearson VUE ATS

Question

Hello. We roll to production next week with our XenApp 7.15 environment running on Windows 2016.

 

If you are in a published Remote Desktop Session the user can see the network drives but not their client drive (c on their client computer) which is preventing them from copying a file.  We had this working in XenApp 6.5.  

 

In doing a little testing today I have confirmed this issue is only when I published a Remote Desktop using the .rdp file.  I started publishing out the .rdp file due to resolution - by default the 'desktop' will take the entire screen and shows up for all users, we need users to only have access to certain desktops.   The users also want to use the Desktop in a 'window'.  In XenApp 6.5, we got around this by setting a percentage of the screen size.  This does not seem possible in XenApp 71.5 and was suggested to publish the .rdp file.

 

The Citrix policies work correctly when I launch an app such as notepad and look at the mapped drives, I can see the client.  Also, as noted if I use the desktop Citrix generates, this will also map the client c drive.

 

If I go back to the RDP file, if I look at Local Resources, select more, and select Drives - this only gives me the Server's local drives and the mapped drives - this does not see a client drive at this point as it doesn't exist, is my guess.

 

Thanks for any thoughts/assistance in advance.

Link to comment

5 answers to this question

Recommended Posts

  • 0

Thank you for your reply and understood.  However; since the reason that we went to publishing out a .rdp file was because the native desktops generated within Citrix consume the entire desktop and will extend to consume both if you have more than one.  So, , though the policies work here when in the native desktop we went the route we did.  If there is a way to publish out the native desktop so it doesn't consume the entire desktop and we can alter like in XenApp 6.5, to a percentage to allow the user to work in a Window, this will solve the situation.

 

So though I've provided what we're doing, I'm open to a better suggestion via Citrix to invoke Citrix policies as well.

 

Thanks in advance.

Link to comment
  • 0

As another thought, I've tried \\tsclient\c$\  and \\Client\C$ as I noticed that when launching the native Remote Desktop session that is allowed via Delivery Controller group, but this is not working.

This is what I've tried adding to the script.

if not exist y:\ net use y:\ \\TSClient\C$ /PERSISTENT:YES >NUL
or
if not exist y:\ net use y:\ \\Client\C$ /PERSISTENT:YES >NUL

Thanks in advance for any other ideas on how to either map the drive or reduce the real estate the Desktop allowed and generated via Citrix Delivery Controller group.

Link to comment
  • 0

This is solved - the real issue was presenting the Desktop - so I was able to move away from published .rdp files which allows Citrix policies to work correctly now.

Key article, https://robertsteeghs.wordpress.com/2018/06/26/configure-custom-screen-resolution-for-a-published-desktop-on-xenapp-7-x/

Basically the key here is once you've added your Published Desktop, to add this into your default.ica file by obtaining the correct ID giving in Citrix with powershell command, Get-BrokerEntitlementPolicyRule.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...