Jump to content
Welcome to our new Citrix community!
  • 0

Windows 10 upgrade default apps reset to blank, snip and sketch tool locks machine after use


David Kurtz1709159055

Question

Upgrading from Windows 1809 to 1909.  

VMware Horizon 7.9

ESXi - 6.7

Applayering - 20.3.0.12

 

Using elastic layers and User layers

 

Having some issues on existing user layers and new user layers with Windows 1909 removing default apps for email\photo viewer and web browser.  Clicking on a browser link will prompt user to set a default, but clicking on a .jpg or .png file prompts "You'll need a new app to open this ms-paint link".   Any way to force these options?

 

Also for some reason the Snip and Sketch tool (windows + Shift + S key) locks up the machine for around 30 seconds.  If you uninstall it seems to work fine.  I have uninstalled on the gold image but it reinstalls when a user logs in.

 

Thanks
David

 

Link to comment

6 answers to this question

Recommended Posts

  • 0

Hi David how are you removing the apps.  Windows 10 can be quite annoying in how it manages UWP apps. 

 

To remove an app you have to uninstall it for any users on the image then remove it

 

Get-AppxPackage -AllUsers -Name Microsoft.WindowsCalculator | Remove-AppxPackage 
Remove-AppxProvisionedPackage -Online -PackageName Microsoft.WindowsCalculator -AllUsers

 

But I am not sure that will help when a user already has installed the app into their user layer.  I think you will need to remove the app as the user then.  You can probably use a logon script based in PowerShell.  For that I think you would only use the first command.

 

Rob

Link to comment
  • 0

note the packagename for the second command is more like Microsoft.WindowsCalculator_2020.2009.4.0_neutral_~_8wekyb3d8bbwe  If you do a get first you will see what it is.

For the default apps i think you will need to see what your settings are.  Just remember with user layers if the user shave changed their that might override anything you set in a layer.  Which may mean you need to script the settings or use GPOs.  

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...