Jump to content
Welcome to our new Citrix community!
  • 1

Store Apps not functioning with Full User Layer?


Terry Duplantis1709152712

Question

Is anyone using the Full user layer in production for Win10 VDI?  We are testing this and are having issues with store apps crashing immediately.  I believe we have identified a potential cause for it, and its related to the following key:

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\[UserSIDHere]

 

Using the exact same image, but with one having the User layer disabled, and the other enabled, we see a disparity of what is stored in this key.  On the working one (user layer disabled), all apps show up in the key, on the non-working one (user layer enabled), there are only a few apps listed there.  Same thing in the RSD keys.

 

 

Link to comment

1 answer to this question

Recommended Posts

  • 0

We have many customers using UL in a W10 VDI random, non-persistent environment. What exactly happens when there is a failure? Which build of Windows 10 are you using? Which AL release is being used? Are you running any scripts that may impact the store apps? Does the same happen when the published image only has the OS and Platform layer, and UL enabled?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...