Jump to content
Welcome to our new Citrix community!
  • 0

Email Alerts Xen Center 6.5


Chris ampyuml

Question

Hi All,

 

I'm pulling my hair out over this so hoping someone can help?

 

Trying to get Alerts sent to an email address but they are failing. I have read many articles, including https://support.citrix.com/article/CTX136679, in my quest to resolve but failed.

 

  • relaying email via an ISP's mail server which requires authentication
  • From the cli of xenserver if I manually send an email using    ssmtp info@DestinationMailbox.com    emails are delivered. So the ssmtp.conf is OK
  • If I then try creating a mail-alarm.conf and generate an alert I receive no email.
    In the  maillog I see Authorization failed (535 Incorrect authentication data)
    The mail-alarm.conf file has the same information regards AuthUser etc as the ssmtp.conf file
  • I have tried many different combinations of config for the mail-alarm.conf but to no avail

 

This is a single Xen server and the Email Options are as below

Send email alert notifcations = ticked
Delivery Address
Eamil Address info@DestinationMailbox.com	- the mailbox trying to send mail too
SMTP Server   X.X.44.43		Port 587

 

Current mail-alarm.conf file

root=xenserver@somebusiness.com
AuthUser=AuthUser@somebusiness.com
AuthPass=YouW0ntGuessTh1s
mailhub=mail.somebusiness.com:587	- ISP mail server
UseTLS=YES

I appreciate similar questions have been asked before but none seemed to have an answer in this case.

As an aside. IS the an easy way to manually create Alerts. Currently I have an alerts set for CPU usage which I trigger by loading the server in question

 

TIA

 

Link to comment

8 answers to this question

Recommended Posts

  • 1

OK so I finally got this to work and all I can say in my case is, https://support.citrix.com/article/CTX136679 is miss leading.

 

I remembered reading a post were the guy had the same issue I have been having mentioned he copied the sSMTP.CONF to the /etc folder and renamed it to mail-alarm.conf and alerts started emailing.

 

So I did the same and email alerts are now being received. I don't understand why it makes a difference as the ssmtp.conf has the same info in it as the mail-alarm.conf but it works.

 

Thanks Tobias for helping

  • Like 2
Link to comment
  • 0

Thanks for the reply Tobias,

Yes StartTLS and various combinations of have been tried in the mail-alarm.conf and ssmtp.conf but always the same..... :48_weary:      Authorization failed (535 Incorrect authentication data) 

The same credentials are used in various other app which send email notifications. Only this one wont!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...