Jump to content
Welcome to our new Citrix community!
  • 0

Upgrade from CVAD 1909 to 1912 LTSR CU1 - Error 1923. Service 'Citrix AD Identity Service' (CitrixADIdentityService) could not be installed


Jens Nesvaag

Question

We have upgrade CVAD 1909 to 1912 LTSR CU1
Uupgrading license server and Storefront server was successfully, 


When upgrade delivery Controller, Director and studio (same server) we get an error 1603 on delivery Controller upgrade.
 ERROR: "Installation of Active Directory Identify Service failedd with error code 1603"


The log file show:

   Log file: Product: Citrix AD Identity Service -- Error 1923. Service 'Citrix AD Identity Service' (CitrixADIdentityService) could not be installed. Verify that you have sufficient privileges to install system services.
Product Name: Citrix AD Identity Service. Product Version: 7.24.1000.10. Product Language: 1033. Manufacturer: Citrix Systems, Inc.. Installation success or error status: 1603.

 

OS version: 2019


Is this a "Log on as a service" problem?

Any Clue?

error.png

Link to comment

1 answer to this question

Recommended Posts

  • 0

After adding login user (domain administrator) and "Network service" to "log on as a service" (gpedit.msc) and stop service "Windows Defender" real-time scan (Gpedit.msc) the upgrade of the first Delivery Controller worked.
I suspect that it was the logon user that we added to "log on as a service" that was the solution to the problem.

On the  second Delivery Controller we get the same error and several of the Citrix Service disappeared after reboot.
After some investigation we found out that we need to restore some folder because they was gone.  We suspect that it was  because the user had securiy problem to upgrade existing files and folder. 
The error log files was in the user profile: C:\Users\administrator\AppData\Local\Temp\Citrix\XenDesktop Installer\....

We needed to restore these folders:
   C:\Program Files\Citrix\Monitor\Service folder
   C:\Program Files\Citrix\ENVTest\Service folder
   C:\Program Files\Citrix\Storefront\Service folder

And we restore some registry key which belong to the service that was gone:
Example: 
   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CitrixMonitor

After an reboot the upgrade of Delivery Controller two worked also.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...