Jump to content
Welcome to our new Citrix community!

Credential Delegation Issue


Craig Mew1709162187

Recommended Posts

Hello, I have an issue whereby I've integrated Netscaler with AzureAD, the authentication works fine and I am redirected to Storefront without any issues.  I'm presented with XenApp Applications as configured, however when I attempt to connect to them I'm presented with a Windows 2012 login screen from the XenApp server.  The username/password & domain are blank, so it's as though the delegation of credentials from Storefront isn't working.

 

However if I go directly to storefront and login, the app launches successfully without any issue.

 

Has anyone has this before and can tell me where to look?

Link to comment
Share on other sites

  • 3 weeks later...

Hey,

 

You need to enable "Delegate permissions verification to Citrix Gateway" so that only the user name (UPN) is verified and used for application enumeration.


See this link:

https://docs.citrix.com/en-us/storefront/1912-ltsr/configure-authentication-and-delegation/configure-authentication-service.html

 

For HDX Start Single-Sign-On, you must implement the Citrix FAS feature so that users do not have to enter their credentials.

 

Cheers,

Daniel

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...