Jump to content
Welcome to our new Citrix community!
  • 0

Cannot finalize app layers after upgrade from 2003 to 2009. “a Microsoft NGen operation is needed”


Rene Tap1709160993

Question

Cannot finalize app layers after upgrade from 2003 to 2009.

When I choose Finalize it comes up with “a Microsoft NGen operation is needed”. It doesn’t matter if I run ngen update several times and I’ve tried it also with the force switch. The registry keys HKLM\SOFTWARE\Microsoft\.NETFramework\v2.0.50727\NGenService\Roots\WorkPending and HKLM\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v2.0.50727\NGenService\Roots\WorkPending both have the value 0

When I create a new layer and open the LayerIntegrity.txt file the message “a Microsoft NGen operation is needed”. Is already there while there isn’t any application installed yet.

 

I’ve restored the ELM to the version before the upgrade every thing works fine again and the is no message in the LayerIntegrity.txt file only “”

 

Thanks

René

Link to comment

4 answers to this question

Recommended Posts

  • 0

In addition to following the article, especially the part to run, ngen eqi 3.. Should you continue to see the message, the OS layer itself may need to complete the ngen operation(s), following the article.. You should add a version to the OS layer, do Shutdown For Finalize. If you see the message follow the steps in the article. Finalize the layer, then use that version to update, create layers.

 

In our latest release, we are doing a better job of detecting and prompting for ngen to be ran, we were not in the past. This is why you may not see the same ngen message using an older release.

 

 

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...