Jump to content
Welcome to our new Citrix community!
  • 0

Gigabyte X570 Gaming X and Citrix Workspace don't play nicely


Jean-Paul Vuissoz

Question

Dear all, this is not a question but description on what I have been experiencing. I am using Windows 10 Pro 2004 which I clean installed in September 2020. My Hardware is:

  • Motherboard: Gigabyte X570 Gaming X with AMI Bios F30 (the latest)
  • AMD Ryzen 7 3700x
  • 32 GB of memory
  • Nvidia GeForce GTX 1650 (also latest drivers installed)

 

Over the last couple of weeks I had several BSOD (mostly irql_not_less_or_equal and CLOCK_WATCHDOG_TIMEOUT) while remote working via Citrix Workspace 2009.6. These BSOD happened several times a day and I was chasing ghosts in the web and trying out several solutions. 

 

Turns out that AMD with their Ryzen CPU has introduced PBO (Perfomance Boost Overdrive) which Auto Overclocks the CPU (one of the many link: https://community.amd.com/community/gaming/blog/2018/08/13/understanding-precision-boost-overdrive-in-three-easy-steps). Since I have switched off this feature on my motherboard I don't have any BSOD anymore. Just as a reminder: the BSOD only happened with PBO switched on and having an active Citrix Workspace session. For normal gaming no issues at all.

 

Thanks and regards

JP

 

PS: I have already contacted AMD and will contact Gigabyte too

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...