Jump to content
Welcome to our new Citrix community!
  • 0

DDNS updates to DNS for GEN1 PVS streamed VDA - Choosing which lease takes precedence?


Jim Smith1709157654

Question

Hi I have a VDA which are Gen1 VMS(SCVMM) and have both a legacy and synthetic NIC as required..

We use PVS for provisioning. 

 

On boot the legacy NIC requests an IP from DHCP and boots the VHDX via streaming it. 

The VDA also requests an IP for the second (synthetic) NIC.

 

On completion of boot the legacy NIC(VDA) releases its IP and uses an APIPA address going forward (which I believe is normal process with these Gen1 boots. (  https://www.jgspiers.com/citrix-pvs-synthetic-nic-streaming-with-hyper-v/ "The Legacy NIC is then given an APIPA address of 169.254.x.x and is no longer used until it needs to PXE boot again on restart"

 

The synthetic NIC keeps its leased IP. 

 

Both NICS request IPs from the same DHCP scope and are on the same subnet.

 

DHCP continues to have both leases active (even though the legacy NIC has a 169 address assigned on its legacy NIC now).

 

DNS is registering the legacy NIC lease address as the A record (ie the one which is no longer assigned on the legacy NIC(its only contiuning to exist as a DHCP lease, not an assignment on the NIC of the VDA) and therefore the A record is wrong (you cannot ping the machine and this is causing a problem as we have monitoring which polls the machine and the monitoring thinks that the machine is down but it isn't, its just that the A record is referring to the NIC which no longer has an IP assigned to it).

 

I reboot the VDA every week at the same time. The issue is evident  as it becomes an incident (cant ping the machine) and I need to delete the legacy NIC lease in DHCP to resolve the issue. 

 

Does anyone know if there is a way to define in DHCP/DDNS/DNS that the synthetic NICS lease should take precedence and then there the A record would resolve to the correct IP?

(or has anyone any ideas of an alternative way for the IP address to be updated correctly after reboot, I have tried to boot from ISO and remove the legacy NIC but Hyper V informs on boot that the NIC is not available, I have also tried to script Ipconfig /updatedns on the VDA but the VDA is not authorized to update its own A record. )

 

My managers think that the server is down but it isn't.

 

Any assistance is very much appreciated. 

 

 

 

 

 

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...