Jump to content
Welcome to our new Citrix community!

Citrix ADC API RSA private key


Recommended Posts

Hi,

 

I was able to create a rsa private key file with help of this document.
https://developer-docs.citrix.com/projects/citrix-adc-nitro-api-reference/en/latest/configuration/ssl/sslrsakey/#operations

 

However I'm not able to download the key files.

I've tried this https://developer-docs.citrix.com/projects/citrix-adc-nitro-api-reference/en/latest/configuration/ssl/sslcertfile/#get-all

But wihtout success.

I get a Status Code 200 while requesting sslcertfile with GET.
But there are no cert files listest in the response.

 

Just this:

 

{
"errorcode": 0,
"message": "Done",
"severity": "NONE",
"sslcertfile": [{}]
}

 

Could someone help me find a way to request the key files via Nitro API?

 

Thank you in advance.

Link to comment
Share on other sites

I'm sending with postman this command.
No Payload defined.

curl --location --request GET 'https://ADC-IP/nitro/v1/config/sslcertfile' \
--header 'Content-Type: application/json' \
--header 'Authorization: Basic ...' \
--data-raw ''

 

Response is this

{
    "errorcode": 0,
    "message": "Done",
    "severity": "NONE",
    "sslcertfile": [
        {}
    ]
}

 

Link to comment
Share on other sites

Understood. I think you are missing query and parameter. Have you tried this already?

https://developer-docs.citrix.com/projects/citrix-adc-nitro-api-reference/en/latest/configuration/ssl/sslcertfile/?_ga=2.16856701.573858295.1602770298-215389659.1583161523#get-all

 

attrs

http:// <netscaler-ip-address> /nitro/v1/config/sslcertfile? attrs=property-name1,property-name2

Use this query parameter to specify the resource details that you want to retrieve.

 

Thanks,

Vamsi 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...