Jump to content
Welcome to our new Citrix community!
  • 1

ica latency 64000ms when adm/appflow enabled


Aaron Baldwin1709153469

Question

10 answers to this question

Recommended Posts

  • 0

We did in fact hear back from Citrix support after a couple weeks with a ticket open. Turns out this is a known bug with Director and can be safely ignored They are working on a patch  to fix it. There is no known fix per se, the only thing they could offer me is a command to put on the netscaler that would "0" out the data basically making it as if there was no rtt.... not a solution imho so well wait for a patch.

Link to comment
  • 0

That's what I was afraid to hear.  This has been going on for months now.

 

1 minute ago, Aaron Baldwin1709153469 said:

Hello,

 

Yes we did in fact hear back finally. the Netscaler team as found it is a "bug" with the director, I've been told it does not actually affect user performance just looks bad in Director. they have been unable to give me a time when it would be fixed however. their current solution is to neuter director in such a way that it doesnt show that data set

 

Link to comment
  • 0

We have a support ticket open since May 2021. I get monthly updates that engineering is working on a fix but it's not implented yet.

At least the release notes of the latest ADC firmware (12.1 Build 62.21/62.27) mention this behaviour  as known issue: 

Quote

 

The ICA latency of a session is recorded incorrectly as 64,000 ms in the Citrix Director when L7 latency is enabled. L7 latency is enabled when the "nsapimgr" knob "enable_ica_l7_latency" is set to 1.
To avoid the issue, set the "L7LatencyFrequency" parameter to 5 by running the following command at the CLI:
"set ica parameter -L7LatencyFrequency 5"

[ NSHELP-23459 ]

 

 

Unfortunately the mentioned workaround does not work for us. But the following helps at least for correct latency-values :

 

1. Enable the EDT Insight functionality using the knob “nsapimgr -ys enable_ica_edtinsight=1”
2. Disable the L7 latency functionality using the knob “nsapimgr -ys enable_ica_l7_latency=0”

 

After reconnect of the session the latency shows correct again but the setting is not persistent, you have to set this after every ADC-reboot again.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...