Jump to content
Welcome to our new Citrix community!

CVPN User RDP bookmarks displaying differently in IE vs Chrome and therefore nonfunctional


KEITH HACHE

Recommended Posts

Hi there,

I've got an NS GW 12 pair that we've been running CVPN RDP icons on for quite some time now. This problem had been reported to me previously, but I didn't start experiencing this issue until I received a new laptop.

 

The portal page has a mix of published RDP Proxied icons and personal ones. We use the personal icons to access our personal desktops.

 

All of this works just fine and has worked fine for a long time; however, here's the wrinkle that I'm hoping you can help me out with.

 

When I login to IE or Chrome, I can access published RDP icons no problems. They download the RDP file and I can connect to the proxied server.

If I try a personal RDP icon in IE, instead of downloading the file and prompting me to open it (launching the RDP client), I get a new IE tab and the message below

Forbidden

You don't have permission to access this resource.

 

If I click on this personal RDP icon in Chrome, Chrome downloads the rdp file, which then launches the session.

 

So, investigating the issue a bit further, when I login to the portal in either browser, the URL in the URL bar (post login) changes to https://mysite/cvpn/<sessionHash>/vpns/portal/homepage.html 

In Chrome, when I mouse over the personal link, it appears the same as the published RDP links do: https://mysite/rdpproxy/RDPTargetServer.mydomain.local 

 

In IE, the URL looks different: https://mysite/cvpn/<sessionHash>/undefined/rdpproxy/RDPTargetServer.mydomain.local  

 

This looks strikingly similar to how webpage links appear when publishing them in the CVPN bookmarks.

 

Of note, if you try to add a bookmark, the "RDP Link" checkbox doesn't appear in the IE popup window; only in the Chrome one.

 

As this didn't previously happen on my old machine (same OS as this one; Win10), I believe this to be a browser preference or something the browser is sending the NS on login to alter the link behaviours for the session.

 

I'd be interested in seeing if anyone's seen this or could comment.

 

Thanks.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...