Jump to content
  • 0

OneDrive Files-on-Demand broken in seamless mode - XA1912 / Server 2019


Steve Ramwell

Question

Hi folks, I'm building a new test environment and have run into a problem with OneDrive Files-on-Demand.

 

Server 2019 1809

CVAD 1912 CU1 - also tested with the 2009 VDA

OneDrive 20.143.0716.0003 (August 2020)

Office 365 2007

 

In seamless apps, when opening any file from OneDrive that is not cached locally ('online only') gives the attached error.

 

Clicking Try Again or Skip closes the error and the file downloads and opens normally. Once the file is available locally it opens fine subsequently. Files that are manually cached via the 'always keep on this device' option also open fine.

 

This only happens in seamless mode. In full desktop, OneDrive online files download and open as expected. It also happens when the test user has local admin on the server, so it looks to not be UAC or permissions related.

 

We're running FSLogix for profile storage, but I have tried with that disabled too, just using a persistent local profile.

 

Everything else is pretty much stock. I added the DisableADALatopWAMOverride & DisableAADWAM reg keys to fix the Office 365 sign-in issue but have tried removing them.

 

Has anyone encountered this before, have a similar setup working, or have any ideas?

 

Cheers!

citrix-onedrive-error.jpg

Link to comment

6 answers to this question

Recommended Posts

  • 0

I have a case opened with both, MS and Citrix. My issue is that we can't passed authentication. Our setup was working since February 2020, but broke sometime last month. They both referred OneDrive not supported on Remote App scenarios https://docs.microsoft.com/en-us/onedrive/sync-vdi-support so we're now stocked with published apps not able to access OneDrive. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...