Jump to content
Welcome to our new Citrix community!
  • 0

Nutanix AHV with PVS BSOD Intermittent


Christopher Grider

Question

Let me sum up our situation: 

 

Current environment is Virt Apps 7.15 CU5 LTSR .. All components (DDC, PVS, Storefront) on 7.15 CU5 LTSR / Currently on vsphere 6.5

Moving from ESXi to Nutanix with AHV for hosting VDA workloads and would prefer to not build a new OS from scratch. 

 

So here are the steps we took:

**Prior to these steps Installed Nutanix PVS Agent on all PVS Servers**

 

1. Reverse Imaged one of our PVS VDA's using P2PVS. 

2. Remove PVS Target Device Software

3. Used Nutanix MOVE tool to migrate machine to Nutanix AHV

4. Keep Legacy BIOS ( NO UEFI )

5. Cloned the new VM to keep as GOLD IMAGE MASTER

6. Cleaned up New VM on AHV (remove VMTOOLS and Ghost Nics etc...)

7. Installed PVS Target Device Software

8. Captured new VHDX (using BDM Boot.iso attached to CDROM as boot method)

9. Snap AHV Master VM without Local HD for PVS to deploy new machines from Snap

10. Verify that Master can now boot to PVS vDisk in both READ/Write and READ ONLY Mode. 

11. Set vDisk to Standard Mode

12. Deploy 3 new VM's using Xendesktop setup wizard in PVS (using new vDisk and PVS Snap )

 

HERE COMES THE PROBLEM!!::

 

These 3 newly deployed machines will boot to PVS and intermittently will either fully boot or will BSOD (No good details) and go into a PVS Boot then BSOD boot loop.  If I shut them down and wait and try again.  They might boot just fine and I can log into the OS or they might BSOD and loop.  When they BSOD they show the PVS server IP and then before showing the Disk they will boot too they BSOD.  If the vDIsk name appears like normal in next PVS boot step.  They boot just fine.

 

** Also tried building a out a VM on AHV and all PVS items needed manually (instead of using xendesktop wizard).. same thing.  intermittent boot or BSOD.

**Yes I am aware of the issue with vmware Nic PCIslotnumber needing to be 192 with similar issue. I have fixed that before. Since that applied to vmxnet3 dont think it applies here. **

 

Anyone else tried this method to move VDA's from ESX to AHV after reverse image and experienced anything similar and resolved it?  Just throwing up a Hail Mary prior to next step of building a new VM with newly installed OS from Scratch on AHV..

 

Thanks for reading.. Hope someone / anyone might have some ideas!

 

Attached are screenshots (not very helpful, but for reference)

 

 

 

BSOD.PNG

Link to comment

3 answers to this question

Recommended Posts

  • 0

Try use one of the new VMs created via XDSW, as a master target.
Open the vdisk in read/write mode (or use a version in mainteance) against that XDSW created target.

 

If that doesnt work, try attaching original local HD to new master (the XDSW created target)
Boot into it, uninstall PVS software reboot, remove all ghost network adaptors, reinstall PVS software, and create new vdisk
 

Link to comment
  • 0

Thanks for the ideas.  I already had tried that unfortunately didn't work.

 

On side note, I just discovered during additional troubleshooting that my machines are booting and starting with 1 IP then a 2nd IP address is being handed out to them.  The first IP is the one assigned in the BOOT.ISO .. The second address has something to do with whatever IP was assigned to the previous machine the vdisk was booted from.  It appears that if the previous machine is down, there is no IP conflict and the vm will boot.  If the other machine is on, there is an IP conflict and the BSOD occurs.

 

Currently investigating why we are receiving a second IP during Boot.  I know that PVS boot does ask twice for an IP, just not sure why its not using the same IP assigned at boot and that is listed in infoblox for the device.  Will update as I learn more.  If anyone has any ideas please post them.. Open to whatever ideas might help.

 

Thanks,

Chris

Link to comment
  • 0

OK... Figured it out.  Forgot that during our seal script we run the recommended DHCP / IP Reg Key cleanup and with the new Nutanix NIC we have a new Adapter GUID in the registry.  Our script didnt account for this because we forgot to modify and add that. :5_smiley:

 

Easy fix in the end, just took me a week to remember this info and update the Seal Script.

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...