Jump to content
Welcome to our new Citrix community!
  • 0

The toolbar has disappeared

Marc Leforestier


Strange thing with the windows version of the workspace.
The toolbar (with home, preferences ...) has disappeared and the desktop is launched in full screen.
Forced to do shift + f2 to switch to windowed mode.
I don't think I made any specific configurations.

I don't have this behavior on macOS. From macOS, the desktop is launched as a window with the toolbar

My desktops are under Windows 10 with VDA 1906.

Anyone have an idea for the toolbar to be displayed on my desktops again?


Workspace is

Edited by marc.leforestier
add workspace version
Link to comment

6 answers to this question

Recommended Posts

  • 0

For me the CDViewer was indeed missing. even after fully removing and reinstalling workspace app. In the end one of my colleagues send me their C:\Program Files (x86)\Citrix files which had the CDViewer.exe . which I could then replace mine with and fix my problem.

Just some extra info for whoever also runs into it.
I noticed something was strange when I got a small citrix load window on top of the normal fully VDI window. after that when the small window disapeard i could still not go to the bar of the VDI.
Prior to copying the files I had already tried different sollutions like check the ICA file if ConnectionBar was on 1 and also fully removing everything workspace related with https://support.citrix.com/article/CTX325140/how-to-remove-client-files-remaining-on-system-after-uninstalling-receiver-for-windows
but neither helped. one thing that did help me but didn't solve it was learning that shft +f2 made the window smaller. that way i didn't have to disconnect my vdi every time i needed to go to my normal desktop.

Link to comment
  • 0

I know this is an old thread but I'm experiencing the same scenario - Win 10 with VDA 2203.  Hundreds of other users are working as expected, with only 1 user impacted, so global settings in the StoreFront are correct.  User moves to different VM's at each log in, so this is not a machine specific issue. 

Things done so far:

- reset users roaming profile: this should clean up any user session specific settings/cache

- remove/re-install Citrix Workspace on user remote PC (Win10 I believe)


Not sure what to look at next. Anyone have any ideas? 


@Marc Leforestier did you ever find a solution?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...