Jump to content
Welcome to our new Citrix community!
  • 0

Unable to upgrade VDA on 2012R2 from 7.12 to 1912LTSR


Eric Arbour

Question

I'm in the process to upgrading our Citrix XenDesktop LTSR 1912, and I have the same problem.

At first, I tried to upgrade the VDA of a 2012R2 server from 7.12 to 1912CU1, I got an error regarding the uninstallation of “Plugin Citrix Monitor Service VDA” with the error 1603. I tried to remove the VDA from the control panel and had the same result. So, I used VDA Cleanup Utility and everything is removed fine.

 

After a couple of reboots, I tried again to install the VDA and I still have the previous result, an error 1603 showing in the result log of the installation.

The msi log of VdaMonitorPlugin_x64 is showing: Error 1721: Problem with this Windows Installer package.

 

The problem is the same with version 2004 of the VDA.

Link to comment

4 answers to this question

Recommended Posts

  • 0

At first, I tried an upgrade from the ISO and it didn’t work. I did a restore of the VM, the I used the VDA Cleanup Utility the I tried again from got again the same error again. Did a restore again, used the cleanup utility again, cleaned up everything in the registry and on the drive of any traces. I also removed all C++ Framework and .Net 4.7. I tried again with the latest VDA from Citrix Download without success.

To be sure that the problem is not with this server only, I tried on another server and had the same error.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...