Jump to content
Welcome to our new Citrix community!
  • 0

WEM 1912 - WEM agent not synchroising - Cached sync schema not available. Reason: Unknown remote database version.


John Morrissey1709152766

Question

WEM 1912 new environment

Unable to successfully have our wem agents interact with the broker

After manually running an agent sync the above warning appears. followed a few seconds later with the following erros:

 

Event ID 0: WEM Agent service

Failed to sync encrypted data. Exception: System.ServiceModel.CommunicationException: The server did not provide a meaningful reply; this might be caused by a contract mismatch, a premature session shutdown or an internal server error.

Server stack trace: 
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: 
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at Citrix.Wem.DBSync.Contract.ISyncProviderContract.GetEncryptedData(String agentPublicKey, Int64 agentVersionStamp)
   at Citrix.Wem.DBSync.Client.Agent.SyncTask.SyncEncryptedData()

 

Event ID 0: WEM Agent service

Citrix.Wem.DBSync.Common.DBSyncException: Cannot sync encrypted data.
   at Citrix.Wem.DBSync.Client.Agent.SyncTask.SyncEncryptedData()
   at Citrix.Wem.DBSync.Client.Agent.SyncTask.DoSync(SyncMode mode)
   at Citrix.Wem.DBSync.Client.Agent.SyncTask.Run()
   at Citrix.Wem.DBSync.Client.Agent.SyncExecutor.Run()
 

Event ID 0: WEM Agent service

Cache sync failed with error: SyncFailed

 

Tried the following articles:

https://support.citrix.com/article/CTX229024

https://discussions.citrix.com/topic/400521-wem-agent-only-launches-at-session-reconnect/

Adjusted the DBSync folder permissions

 

Any ideas much appreciated

Link to comment

3 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...