Jump to content
Welcome to our new Citrix community!
  • 0

Secure Hub - No longer communication with Xenmobile server


Paul Forest

Question

Hi everyone,


Some users try to install a new apps from entreprise store (not from Google Play or Google Play Entreprise) and they can not download it.
 

I did a test with a user, he has tryed to downlaod a new app at 12:01PM, but nothing. I saw the user on xenmobile but it is on "Inactivity"


I got the SecureHub log and I have some errors

I didn't see anything on log's server for this one. I think I didn't receive any informations from securehub.

 

I have tryed some basic action : Reload policies, try download other app's, trying on 3/4G etc... but nothing resolve the issue.

 

Here log to CtxLog_com.zenprise.csv

"2020-08-24T12:01:02.841+0200","SecureHub","INFO      ( 4)","KernelService:Setting up last external event to current time: 8413372",11139,11139,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.841+0200","SecureHub","INFO      ( 4)","KernelService:Connection is not busy. Interrupting the communication thread",11139,11139,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.842+0200","SecureHub","INFO      ( 4)","KernelService:connecting to server",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.845+0200","SecureHub","INFO      ( 4)","Util:Setting the serial type to: generic2",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.845+0200","SecureHub","INFO      ( 4)","com.citrix.work.featureflag.FeatureFlagController:FeatureToggle: getFlagStatus Feature flag state: android.imei.meid.fix:1",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.845+0200","SecureHub","INFO      ( 4)","Util:getIMEI():Should MEID returned if IMEI not found? false",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.852+0200","SecureHub","INFO      ( 4)","SHTP:Secure hub is trying to connect to server.",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.867+0200","SecureHub","ERROR     ( 2)","Cert: 
java.io.IOException: KeyStore integrity check failed. 
        at org.bownzycastle.jce.provider.JDKKeyStore.engineLoad(JDKKeyStore.java:727) 
        at java.security.KeyStore.load(KeyStore.java:1545) 
        at com.zenprise.certificate.Cert.getCertificates(Cert.java:306) 
        at com.zenprise.communication.SHTP.connectInternal2(SHTP.java:449) 
        at com.zenprise.communication.SHTP.connectInternal(SHTP.java:384) 
        at com.zenprise.communication.SHTP.connect(SHTP.java:365) 
        at com.zenprise.communication.KernelService.connectToServer(KernelService.java:815) 
        at com.zenprise.communication.KernelService$1.run(KernelService.java:355) 
",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.903+0200","SecureHub","INFO      ( 4)","EMMUtil:isAFWEnrolled: false",11139,11139,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.904+0200","SecureHub","INFO      ( 4)","EMMUtil:isAFWEnrolled: false",11139,11139,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.928+0200","SecureHub","INFO      ( 4)","SHTP:Secure hub is connected.",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:02.966+0200","SecureHub","WARNING   ( 3)","AsyncTaskEventHandler:Activity is either null or in process of finishing, so not dismissing progress dialog.",11139,11139,Secure Hub,  ,  ,0 
"2020-08-24T12:01:03.221+0200","SecureHub","INFO      ( 4)","com.citrix.work.MAM.PolicyCheck:Run local root check",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:03.359+0200","SecureHub","INFO      ( 4)","SHTP:statuscode =400",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:03.368+0200","SecureHub","ERROR     ( 2)","SHTP:Secure hub failed to connect with status = 0",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:03.368+0200","SecureHub","WARNING   ( 3)","SHTP: 
java.io.IOException: Connection failed, status=400 subcode=HTTP/1.1 400 SHTP0003: A required parameter is missing. 
        at com.zenprise.communication.SHTP.connectInternal2(SHTP.java:667) 
        at com.zenprise.communication.SHTP.connectInternal(SHTP.java:384) 
        at com.zenprise.communication.SHTP.connect(SHTP.java:365) 
        at com.zenprise.communication.KernelService.connectToServer(KernelService.java:815) 
        at com.zenprise.communication.KernelService$1.run(KernelService.java:355) 
",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:03.369+0200","SecureHub","INFO      ( 4)","SHTP:Secure hub has disconnected",11139,11493,Secure Hub,  ,  ,0 
"2020-08-24T12:01:03.371+0200","SecureHub","ERROR     ( 2)","SHTP: 
java.io.IOException: sslWriteThread 
        at com.zenprise.communication.SHTP$2.run(SHTP.java:794) 
        at java.lang.Thread.run(Thread.java:764) 
",11139,22902,Secure Hub,  ,  ,0 

Did you have any information about this issue?

 

thank you so much.

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...