Jump to content
Welcome to our new Citrix community!

NetScaler stuck at spinning circle when trying to add an SSL certificate.


Recommended Posts

Currently running NetScaler VPX 200 v12.1 57.18nc

 

System itself runs fine and has been working great. Issue is that our wildcard cert is expiring and I need to replace them. I tried importing a .PFX as well as generating a new key and requesting a cert from DigiCert.

 

What I run into is just a spinning circle... Nothing else. I've tried restarting and doing a complete shut down and power on. I've tried copying the cert to the appliance and then installing. I keep getting the same result! I've let it sit for over an hour to make sure I wasn't just being impatient, but I can't get past the spinning circle.

 

I've read the instructions here - https://www.carlstalhood.com/netscaler-12-certificates/

 

Nothing seems to be working... Help!

Link to comment
Share on other sites

On 8/25/2020 at 2:28 AM, Carl Stalhood1709151912 said:

What browser?

 

You can use the CLI to run something similar to the following:

 

add ssl certkey myCert -cert mycert.pfx -inform PFX 

 

Carl, that was the trick! I installed the certificate through the cli as you suggested and it worked. I was able to bind those certs to the virtual servers and everything is back online and working.

 

FYI - I was getting the spinning circle in Chrome Version 84.0.4147.135 and IE 11.959.18362.0 (11.0.200 Update)

 

Thank you!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...