Jump to content
Welcome to our new Citrix community!
  • 0

Start Menu Issue server 2016 1912


Christopher Burry

Question

I am using Citrix 1912 for PVS and VDA and currently have an issue with random users unable to open the start menu. When clicked on all that happens is the blue circle spins like it will open. I have worked with Citrix Support and have had no success so far. It happens randomly and resetting the profile or just having the user sign out and wait until it shows they are signed out of Citrix using Director and then have them sign back in once they are logged out. We find that the users that have the start menu issue take around 5-6 minutes to be logged off of Citrix compared to others where it takes less then a minute. I just recently took over Citrix from a former employee so I am pretty new to all of this so any help would be greatly appreciated.

Link to comment

3 answers to this question

Recommended Posts

  • 0

I've done extensive testing and research, and the most consistent settings that worked for us are the following UPM and Registry settings:

 

Disable Automatic Configuration:

Enabled

 

Exclusion List - Directories:

AppData\Local\Packages

 

Exclusion List - Files:

AppData\Local\Microsoft\Windows\UsrClass.dat*

 

Folders to Mirror:

AppData\Local\TileDataLayer
AppData\Local\Microsoft\Windows\Caches

 

Create VBS file to register Start Menu at login using Run key in User Profiles (applied with GPO):

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run - "\\network\path\RegisterStartMenu.vbs"

 

RegisterStartMenu.vbs:

Set objShell = CreateObject("Wscript.Shell")  
Dim PSRun
PSRun = "powershell.exe -WindowStyle hidden -ExecutionPolicy bypass -NonInteractive -NoProfile -File "\\network\path\RegisterStartMenu.ps1"
objShell.Run(PSRun),0

 

RegisterStartMenu.ps1:

Add-AppxPackage -Register "C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\AppxManifest.xml" -DisableDevelopmentMode -ErrorAction SilentlyContinue
Add-AppxPackage -Register "C:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\AppxManifest.xml" -DisableDevelopmentMode -ErrorAction SilentlyContinue

 

 

You can also read through this thread (one of hundreds on the internet):

https://discussions.citrix.com/topic/391754-windows-2016-start-menu-blank-icons-with-715-cu1/

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...