Jump to content
Welcome to our new Citrix community!
  • 0

Store Front keeps coming up and blocking access to workspace when logging in with Citrix Receiver/Workspace


Aminollah Sabzevari

Question

I have been logging into my workspace for years, by going to my company's website in a url website, and then logging in with user name, password, and a passcode generated by a cryptocard. The system uses Citric, which after logging in at that website opens up to load up my workspace and then runs the various apps (outlook etc) when I ope then. So I never actually open up Citrix myself, it just loads up when I log in. It was using Citrix Receiver for years, now it uses Citrix Workspace, which initially worked but now runs into this issue below.

 

After I log in, it opens up this storefront login (see attached), that never used to come up before. I made a Citrix account and tried to use that to login but it doesn't work. My work user name and password doesn't work either nor did I really expect it do. I am not sure why this storefront page keeps coming up, and there is no way to bypass it to get to my workspace. 

 

I tried uninstalling workspace and going back to receiver but it has the same problem, and keeps prompting to detect or install workspace, so I've stuck with workspace. Citrix workspace is open on my computer as I see it in the system tray. Ultimately, I get as far as this log in page and that is it as I can't log in past it. 

 

I appreciate any help you may be able to provide. 

storefront.png

Link to comment

3 answers to this question

Recommended Posts

  • 1

If I understand correctly, you historically opened a corporate website, logged in and were redirected to your approved applications in Citrix.    In your screenshot, you show a Citrix Storefront login screen.  This is typical (and correct) behavior so far.  Without seeing a screenshot of the site you used historically, I can't say for certain but my guess would be that it might have been a previous version of the Citrix web frontend (called Web Interface).  If not that, it was possibly a generic website that prompted you for credentials and then through Single Sign On, passes your credentials into the Citrix frontend and you had access to your applications.

 

My guess is that your company has upgraded to a recent version of the Citrix and you're now confused with the new look.  You would typically need to supply your company's domain credentials to login and see your applications.  The other scenario is that their Single Sign On solution is not working.  

 

Your screenshot does not show a prompt for the Smart Card passcode but they may have it configured to prompt you after supplying your credentials.  

 

In any case, as was already suggested by Nicolas, you need to engage with your IT support Helpdesk for support. 

 

 

  • Like 2
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...