Jump to content
Welcome to our new Citrix community!
  • 0

Citrix 1912 CU1 Host to Client Redirection


Question

Hi All,

 

Environment:

server 2016 - fully pathced

Citrix 1912 CU1

 

 

Hoping this is a simple question.

 

I'm trying to get host to client redirection working so when users click url's in an app to opens in the client browser and not the VDA browser.

 

I've enabled the policy.  I've set the registry changes following:

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/1912-ltsr/general-content-redirection/host-to-client-redirection.html

 

I've made the group policy changes following the same document (placed on a network share) and stopped there.  I didn't set a specific set of websites or change the list of URL types for redirection.

 

Every time I click on the URL in the app it opens in IE11 from the VDA.  I published a test desktop for a test account hoping to get more information and opened wordpad and typed www.google.com and tried to launch in and received "wordpad was unable to open the url" error message.  I eventually called Citrix and low and behold it worked when talking to them and the link opened in Chrome.

 

So I created a new test user and tried the published app and it's opening in IE11.  Tested the original again, and it works.  I don't understand why this works for the first users and not any others currently.  The only thing I know that I've done differently is logged into the published desktop.  So tried that with the new account, and it didn't help.  I'm baffled why this doesn't work and the lengths needed to make it work. 

 

Anyone ever come across this yet ?  or have any suggestions ?

 

 

Link to comment

6 answers to this question

Recommended Posts

  • 0

Hi, 

 

I am having the exact same issue. We have tried the trusted white list for sites, upgrading from 7.15 CU4, to CU5 as suggested. Then to CU6. We then proceeded to upgrade to 1912 CU2 as suggested by Citrix. Nothing is working. When i log directly onto the VDA via RDP and open IE and trust the security settings, then the redirection works fine.

 

At whit's ends with Citrix on this. We have been going at this since last September...

Link to comment
  • 0

Hi there,

 

I just did the same thing and its working. Iam guessing your issue is setting/changing the UserFTA (in HCU\SOFTWARE\Microsoft\Windows\CurrentVersion\shell\....). The Citrix Article covers this by using/deploying the DefaultAppAssociations.xml via GPO, which isnt working like a charm to be honest. :)

 

Check out SetUserFTA.exe and try setting the UserFTAs like this (Logon-Script, WEM External Task, whatever you like):

 

"...\NETLOGON\Tools\SetUserFTA.exe" http ServerFTAHTML 

"...\NETLOGON\Tools\SetUserFTA.exe" https ServerFTAHTML 

 

Hope this helps

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...